Hass.io Play Radiostream

i installed “mopidy and snapcast”, configured spotify on it, set it as mpd in the config file, set output to “audiojack”:

“local_scan”: false,
“options”: [
“name”: “audio/output”,
“value”: “autoaudiosink”

moped connects to spotify, i can choose a playlist and play it. On the startscreen of home assistant i can see that it found the mpd service and shows what is playing in spotify right now.
So config seems correct, but nothing is coming out of the audiosink. tried to send something with TTS. but also no luck.

What can i do to make it work?

Running on a Rpi3, i have mine configured as:

  "local_scan": true,
  "options": [
      "name": "audio_output/type",
      "value": "alsa"
      "name": "audio_output/device",
      "value": "hw:1,0"

Thank you. Tried it, but still no luck. That “alsa” is the virtual output used by snapcast, right? Do you get output from the raspberry when attaching an AUX Cable?


Uninstalled “mopidy and snapcast” and installed just mopidy, and put no options besides spotify worked as audio output. Maybe the bundle with snapcast is not meant to play local music.

Update again: Installed mopidy and snapcast" and “snapclient”. Now i have local audio and network audio

1 Like