HASSbian not working out of the box

I’m pretty new to Linux and HASS, but wanted to report in on what worked for me for posterity.

After burning the HASS1.1 image (2017-02-03-HASSbian.img) to an 8GB SD card in a USB adapter attached to my Pi3B (via linux command-line dd), then inserting the burned SD card into my Pi with attached monitor and keyboard/mouse (but no ethernet), I could boot the Pi to a login screen. I changed the password and waited at the command prompt for nothing to happen. I connected ethernet and rebooted, coming to the same command prompt. Logging in did not start any action other than blank/idle command prompt. I could not log in from another computer via HTTP to http://hassbian.local:8123/ nor to http://[THE_PI_IP_ADDRESS_HERE_NO_BRACKETS]:8123/ .

What worked for me
After trying the below, getting stuck in a boot loop, and re-flashing the image with win32diskimager, I got mine working with

sudo ./usr/local/bin/install_homeassistant.sh

It takes about 2 minutes to connect through http://hassbian.local:8123

HTTP access is still functional after rebooting

There should be directory in ~ now called hassbian-scripts

update: After installing duckdns cron, I learned that I had to follow the other suggestions from above posters too:
add “ hassbian” to /etc/hosts using

sudo nano /etc/hosts

Other attempted solutions (didn’t work for me)
I added “ hassbian” to /etc/hosts, as suggested by this thread (and another forum), which didn’t fix immediately

sudo nano /etc/hosts

I attempted to install services suggested by another thread

sudo pip3 install --upgrade aiohttp
sudo pip3 install --upgrade homeassistant

I checked to see if the HASS service was running via

sudo systemctl status [email protected]

(note: I had to change keyboard bindings from UK to US to get the @ sign working. I did this via sudo raspi-config then changing the keyboard in “localization settings”)

It had been loaded, but had failed to run:
Started Home Assistant for homeassistant.
[email protected]: main process exited, code=exited, status=203/EXEC
Unit [email protected] entered failed state

I attempted rchiarelly’s fix (this thread) by navigating to

sudo nano /etc/systemd/system/[email protected]

and trying “ExecStart=/usr/local/bin/hass” to no avail.

Like the previous commenters, I noticed that there is no “hass” located in /srv/homeassistant/bin/ but there is a “hass” located in /usr/local/bin/ . I navigated to the directory and ran hass manually. This engaged the setup of hass, and after 5 minutes of updating the HTTP server was working on my network!

cd ~
cd /sur/local/bin/

However, rebooting the pi did not autostart hass again. I tried

sudo nano /etc/systemd/system/[email protected]

again to check spelling of “ExecStart=/usr/local/bin/hass” and to try “ExecStart=hass”, to no avail.

Addding hass to rc.local caused my Pi to be stuck in a forever-booting-and-not-responding-to-console-during-hass-launch-while-no-http-access loop.

Hello, I’m new in the forum. I have problems with the image I have downloaded.
No connection to the host. Then I tried to add a monitor to the raspberry pi how it boots but gives a “kernel panic” message at the end of the initial lines.

Make sure you’re connected via Ethernet when you first boot. See how that goes…

I have the same issue. i have ethernet connected (has to be a DHCP enabled port) but when i load hasbian for the first time it runs for 1 minute then askes for hasbian logiin and just does nothing else.

In my limited experience, it does some stuff without showing what it’s doing. I thought it wasn’t working, then a few minutes later, hassbian.local became available. Maybe yours is doing the same.

I seem to have found the problem.

for some reason after you have installed hassbian, and set the dhcpcd file to static the pi gets lost and will not connect to any network, change the settings back to dhcp and use a Ip scanner to look for it then it works and can connect.

Thanks a lot for your help. It was a SD issue B.Rgds.

I have the same problem and I am going mad now. What are the steps to get home assistant working please as I have tried everything.

I likewise just tried to install the latest Hasbian (1.23) on a Raspberry Pi v1 (which has run HomeAssistant before using the all in one installer), and have the problem of no WebUI, but I can SSH in fine.

sudo systemctl status [email protected]

Gives the following output
[email protected] - Home Assistant for homeassistant Loaded: loaded (/etc/systemd/system/[email protected]; enabled) Active: failed (Result: exit-code) since Tue 2017-05-09 20:04:04 UTC; 9h ago Process: 746 ExecStart=/srv/homeassistant/bin/hass (code=exited, status=203/EXEC) Main PID: 746 (code=exited, status=203/EXEC)

May 09 20:04:04 hassbian systemd[1]: Started Home Assistant for homeassistant.
May 09 20:04:04 hassbian systemd[746]: Failed at step EXEC spawning /srv/homeassistant/bin/hass: No such file or directory
May 09 20:04:04 hassbian systemd[1]: [email protected]: main process exited, code=exited, status=203/EXEC
May 09 20:04:04 hassbian systemd[1]: Unit [email protected] entered failed state.

And indeed, looking at the failure, there is no directory /srv/homeassistant/bin/hass

Does anyone have any suggestions as to a solution?

I’ve also just noticed my Pi seems to think its May 9th, but I’m guessing that is unrelated?

Credit to @Kem this is what you need to do

sudo apt-get update
sudo apt-get upgrade