Hassio new installation asking for username and password

I’ve always managed to get straight in with the IP but I’ve always made sure it’s fixed before I start.

Not sure why TT is reluctant to do this?

Not sure if he’s reluctant or just inexperienced with Linux. At any rate the point of the hassio.local address is so that you don’t need to find the dhcp address after installation. And setting a dhcp reservation in the router is perfectly valid.

Point is, if he can access the login page then we’re past the point of needing to worry about static vs dynamic ip.

1 Like

If it’s still not working the next step is to try to access the SD card from another computer, navigate to the /config directory, edit configuration.yaml, and set a password.

The fact that OP is using a windows computer complicates things however…

yes, just failed again.

Somebody else mentioned editing that file, but can it be done on a Windows computer is the question?

yes definitely

this is weird because I actually get the same problem with hassbian. Instead of just going straight into the setup, it asked me for the password.

raspbian GN U/Linux 8 hassbian TTY 1
hassbian login:

So I put

Login incorrect

so I am going to load raspbian onto another SD card, and then see if I can edit that file people mentioned.

So I put Raspbian on an SD card and then place that in my raspberry Pi 3. Switched on.

Inserted SD card reader, and then inserted the SD card with Hassio

This is what I saw

And this is what I saw when I did a search for config

I also tried a search for "configurations.yaml
Any advice appreciated, Tremulous Tetra. :slight_smile:

this is the Raspbian I downloaded

all downloaded onto raspberry Pi 3

Okay, finally had some success. My computer;
Dell XPS 18 Touch Screen 3 1ghz i7 8GB RAM 250GB SSD 8 GB cache Desktop Tablet 18".
Can only connect to Wi-Fi, there is no network cable connection socket.

So I got my son to try on his desktop in the same house. His desktop computer is plugged into a plug socket network adapter, and the raspberry Pi was plugged into the same adapter. Using;
didn’t work.

But using;
took him straight to;

Neither of the command work for me on my Wi-Fi connected desktop/touchscreen.

So then I plugged the raspberry Pi into a network adapter in a different room to my son, my son was still able to connect to the raspberry Pi/hassio.

So it seems the problem all along was the lack of a network cable.

Any luck yet TT?

I had a similar problem the first time starting a fresh install of hass.io in my pi3. Turned out I would only get the logon screen with Internet Explorer. Tried Chrome and it all worked exactly as expected. No need to edit anything to get started.

1 Like

OMFG!!! I cannot believe that. Spent nearly 2 weeks on this problem. I even bought myself a USB network adapter so I could plug my computer straight into the network. I assumed it was that, as everything works correctly on my sons computer. But he uses Google Chrome as standard. Still can’t bloody believe it, use Google Chrome instead of Internet Explorer, and everything is working fine.

Feel like punching something, good job I’m paralysed from the neck down LOL

Any advice appreciated, Tremulous Tetra. :slight_smile:

Glad you’re sorted but can’t believe you’re using a long dead product like Internet Explorer on the web, have you no interest in a decent web experience and, more importantly, some security?

1 Like

my prime concern when using a PC is being able to use Dragon NaturallySpeaking, now known as Dragon professional individual 15. I’ve been led to believe that Internet Explorer is the most compatible. Hence my continued usage.

Which would you recommend?

Any advice appreciated, Tremulous Tetra. :slight_smile:

I believe this explains it!

everything working good now?


Lol, not seen that before :smile:

Anything you can keep up to date but their website says it’s compatible with chrome and edge. Personally I use chrome as I like the whole Google ecosystem and being the most widely used you’re less likely to find any sites that don’t work with it.

Just tried Google Chrome, not compatible with SpeechStart+ software, RoboForm, and Dragon NaturallySpeaking the way Internet Explorer is. In fact, even when I press control shift N, it doesn’t bring up private browsing. Never has worked for me that.

Any advice appreciated, Tremulous Tetra. :slight_smile:

If the incognito shortcut doesn’t work it kind of suggests there’s something wrong with your set up!

Otherwise it just sounds like you’re suffering from trying to use old poorly supported software and you know what the minor consequences of that are from the weeks you’ve wasted on trying to ‘fix’ a perfectly OK version of HA, the major consequences are far more serious!

Good point well made Sir. :+1:

I notice you didn’t include in your list of browsers Microsoft edge. Bad also? In your opinion?

Any advice appreciated, Tremulous Tetra. :slight_smile: