HassIO random crashes and restarts

I have been experiencing many random crashes of HassIO since a couple of updates ago…I thought this would have been sorted by now, I don’t know how to trap the code and find out whats causing it as all I get after the reboot is this…I have checked power and it’s not that

Ended unfinished session (id=17 from 2019-06-09 20:46:46.260078)

Any ideas anyone…

All my switches for automation are reset as well, which is a real pain

Hi. Check your power supply if you are on pi. I saw that message when electricity was lost. And I had same issue with 1.5A power supply. No issues with 3A

Sorry I wrote that I have checked that already…Its a 2.4A power supply so enough current. I have also replaced it with the same…It’s been working fine for a number of years

You could use an automation triggered on a system log error or warning event to write to the file notification. In this way you could construct your own system log that is persistent across restarts.

This is untested:

notify:
  - name: persistent_log
    platform: file
    filename: persistent.log ### will be in /config

automation:
  - id: my_system_log
    alias: 'My Persistent Error Log'
    initial_state: true
    trigger:
      - platform: event
        event_type: system_log_event
        event_data:
          level: WARNING
      - platform: event
        event_type: system_log_event
        event_data:
          level: ERROR
    action:
      - service: notify.persitent_log
        data_template:
          message: '{{ trigger.event.data }}'

I think it has something to do with Loop Energy…if I disable it…there are no more crashes…I know they worked on it the update before last and it was fine…but now it is crashing HassIO good and proper again in 0.94.2

I have the same in latest 0.110 and 0.110.1 version. It restarts randomly and I don;t know why. I have the same info in log as You. It was working just fine in 0.109.6. Did You manage to solve it?

Unfortunately no I didn’t resolve it. Currently Loop Energy is commented out of my config.yaml. No one has updated the loop energy integration for some time so I guess it’s a dead duck now.