Hassio with external NVR

Hei everyone
I’m as new as can be to home assistant, and this might be very obvious for some of you.
I am considering setting up a surveillance system. I plan on using IP cameras, but i can’t seem to find any information or guides about having an external NVR, but being able to acces the feeds from Home assistant. I have door and window sensors setup so that i get a notification when someone opens them when i’m not around.
Is it possible to have an external NVR record 24/7, while being able to access the feed from HA?
Just fyi, I know about blue iris, but I plan on using a dedicated NVR from hikvision (I can get it cheap from work).

Thanks in advance :slight_smile:

Before I answer the question, Hass.io is how you installed Home Assistant, the software you’re running.

Yes you can, as long as your NVR supports one of the protocols that Home Assistant supports for cameras. A bit of quick Google searching suggests that it supports RTSP, so you can use the generic camera component, possibly others.

If goal is viewing recorded images, you can do but this requires some script or backend code and creative use of HA components.

You can probably setup NVR sensors as HA sensors using HA API if your NVR supports this via code. If NVR has physical sensor output you may use device like RasPi or ESP8266 to ingest single and output to mqtt for HA.

Live streams you can use RTSP, Generic or FFMPEG component direct from cameras or through NVR

I am currently trying to get generic camera to work, but i get this error: Invalid config for [stream]: expected a dictionary for dictionary value @ data[‘stream’]. Got [OrderedDict([(‘platform’, ‘generic’), (‘still_image_url’, ‘http://admin:[email protected]/ISAPI/Streaming/channels/101/picture’), (‘stream_source’, ‘rtsp://admin:[email protected]:554’)])]. (See /config/configuration.yaml, line 109). Please check the docs at https://home-assistant.io/components/stream/

Do you know what i am doing wrong?


I mean, how can I when you don’t show us what you’re doing :man_shrugging:

ups sorry, This is what i added in my configuration.yaml file


I am trying to get it to show the feed in lovelace frontpanel.
and i have set the picture entity card up like this
type: picture-entity
entity: camera.cam_1
camera_view: live

Please see the messages in the banner about how to format your post. Probably the issue is with your formatting, but we can’t tell if you just throw it into your post like that.

Thanks, it turned out to be just that.
I do still have it say inactive in the camera overlay

It works fine but is there a way to remove that?
Sorry, i’m a bit new to HA and coding in general.

The picture entity card has a bunch of options, including whether to show the state and the name in the footer, set show_state to false

I fear i might have messed it up.
I was planning on have the camera show in Hassio lovelace and then setup a NVR seperately to record 24/7.
I had the camera working on the lovelace page. But after i installed the NVR it no longer shows the feed. I double checked the ports and ip address. And if i follow the still_image_url in a browser i still get the picture. But i cant get it to show on the frontpage. Do you know what i did wrong?

1 Like


have you succeed please?

i have 15 camera in HassOs (Rpi0w, esp32cam, TapoC310 and c200), work great, but i have made a NVR with AgentDVR (ispy) and a RPI4 and when i start the NVR (just display the 15 feed of camera) my wifi (ubiquiti x1 AP-AC-PRO and x2 AP-AC-LR) seems to became crazy…all the sensor in ESPHome disconnect one after the other…complete mess…

And when i record all the streams…the Wifi turn mad…more problem of disconnections and reconnection in loop…

I have a standard config for esp32cam and i just add the new component :

  - port: 8080
    mode: stream
  - port: 8081
    mode: snapshot

here is my config :

  name: bureau
  platform: ESP32
  board: esp-wrover-kit

  password: "xxxxxxxxxxxxxxxxxxx"
  fast_connect: on
  power_save_mode: none

# Enable logging

# Enable Home Assistant API

  password: "xxxxxxxxx"

  - port: 8080
    mode: stream
  - port: 8081
    mode: snapshot

    pin: GPIO0
    frequency: 20MHz
    sda: GPIO26
    scl: GPIO27
  data_pins: [GPIO5, GPIO18, GPIO19, GPIO21, GPIO36, GPIO39, GPIO34, GPIO35]
  vsync_pin: GPIO25
  href_pin: GPIO23
  pixel_clock_pin: GPIO22
  power_down_pin: GPIO32
  vertical_flip: false
  horizontal_mirror: false
  resolution: 640x480 

  name: bureau
  - platform: wifi_signal
    name: "WiFi Signal Bureau"
    update_interval: 60s
    id: signalWbu

  - platform: restart
    name: "Restart Cam Bureau"
  - platform: gpio
      number: GPIO13
    name: "Bureau PIR Sensor"
    device_class: motion

# Flashlight
  - platform: gpio
    pin: GPIO4
    id: gpio_4
  - platform: binary
    output: gpio_4
    name: $hostname lightbur

If someone can help please :

So my question is : can we stream in HA and at the same time in a NVR?

For my knowledge…its a stream…so can be read at the same time on several machine…in theory…because it doesnt work very well…

Does i need to configure something special in my APs?


Please read this sticky post @Olivier974

All that config is for ESPHome, not Home Assistant

And yes, you can stream in your NVR and HA at the same time. All you need is a network capable of handling it. Sounds like you have a problem with your WiFi not having enough bandwidth for 15 feeds.

ok sorry…doesnt know its no polite or respectfull to tag…just want to have some attention, understand now its not the way…

thanks for your reply,

i understand like you that my network have some trouble to handle 15 feed…need to make some change were the NVR is wired…to test

last question : so the esp32_camera_web_server: + api: isnt a problem in EspHome?

And this is why the sticky post exists, so that you know what is expected of you.

Wired will be best

I have no idea - maybe somebody else will know

1 Like

just in doubt…i dont understand the number 16 of sticky post you gentle invite me to read because :

First Mention
This badge is granted the first time you mention someone’s @username in your post. Each mention generates a notification to that person, so they know about your post. Just begin typing @ (at symbol) to mention any user or, if allowed, group – it’s a convenient way to bring something to their attention.

this badge is a nonsense with the sticky post…

Sorry, English is not my native language…