Have i bricked my first device ? Deltaco SH-P01

I bought 3 of these inexpensive little wall plugs after reading this topic: Deltaco SmartHome

So two of them won’t flash in Tuya Convert but one of them did so let’s focus on that one first. After the usual tips and trix I got it flashed with Tuya Convert and then I flashed it with a ESPhome bin. But something went wrong during the ESP flash and now the device only shows up as the fallback hotspot. The real problem is that a can’t log in to that fallback network. I only get wrong password…:frowning: So please tell me…is this my first brick ?

This is the code that I compiled and flashed:

  name: smartplug_deltaco_1
  platform: ESP8266
  board: esp01_1m

  ssid: “XXX”
  password: “xxxxxxxxxxxx”
  # ...
    # Set this to the IP of the ESP
    # Set this to the IP address of the router. Often ends with .1
    # The subnet of the network. works for most home networks.
  # Enable fallback hotspot (captive portal) in case wifi connection fails
    ssid: "Smartplug Deltaco 1"
    password: “1357908642”


# Enable logging

# Enable Home Assistant API
  password: “1357908642”

  password: “…”

  - platform: gpio
      number: GPIO13
      mode: INPUT_PULLUP
      inverted: True
    name: "Deltaco SH-P01 Button"
      - switch.toggle: deltaco_relay_1
  - platform: status
    name: "Deltaco SH-P01 Status"

  - platform: esp8266_pwm
    id: deltaco_smartplug_blue_led
      number: GPIO5
      inverted: True
  - platform: gpio
    name: "Deltaco SH-P01 Relay"
    id: deltaco_relay_1
    pin: GPIO12

  - platform: monochromatic
    name: "Deltaco SH-P01 blue LED"
    output: deltaco_smartplug_blue_led

Just to be super clear, the only thing showing up is this network: Smartplug Deltaco 1 and the password is wrong so I can’t connect.

Welcome to the forum.

Please read this post, particularly point 11 and then edit your post to get your code in the right format :slight_smile: How to help us help you - or How to ask a good question

Sorry about that, fixed it now.

I had a play last night, deliberately mis-spelled the password. You need to connect to the captive portal quite quickly.

Even if I try to connect as soon as possible when the fallback hotspot is online I can’t connect. In my config can you se if I have a error? The plug should just find my normal wifi and have IP:

I expect you have mis-spelt your password or ssid.

Or else your device is too far from the AP, or is broken :slight_smile: