Help me love HA - first (failing) automation, Daikin AC with BRP069B45

Hi, I have been reluctant to IoT, the fragmentation and the proprietary cloudish security and privacy nightmare. In fact I really tried not to buy fridges with wireless :grinning:

As there is no escape, I have to make the best of it, so Home Assistant seems to be the answer. Have a lot of plans, but thought to start with a new Daikin Comfora Bluevolution FTXP25M-RXP25M Inverter 9000 BTU AC. I also bought as per the HA docs a compatible Wifi Daikin BRP069B45. I mean - I didn’t bought a better AC unit, as I wanted this stuff :slight_smile:

Set up the network for the AC, routing done by OPNsense with a decent Xeon-D, Unifi 6 Lite AP, Cisco&Microtik switches, VLANS fine, configured the Daikin controller, all bells and whistles; installed HA as a community plugin in TrueNAS, configured roughly, added the Daikin integration. The networks talk to each other so I am quite sure it is not an issue.

Quite important I guess: everything else works except the automation as a whole so I can see the temperatures from its sensors, start/stop manually, set/change things in the AC, etc no problem. Even parts of the automation as it respects everything else, when the AC is on that is! Just can’t figure how to start the damn thing, when it is off.

I am trying to achieve a very simple thing right now: start the silly AC when a certain temperature is reached. After 3 days I am at the end of line. I deleted everything so pls don’t ask for configs, just tell me pls how to start an AC with an HA automation, and I will take it from there, as reading doesn’t help.

I really want to love this, but so far nothing works completely: can’t add Kodi via ssl, nothing for the LG smart TV and fridge, the stupid Daikin not starting, why is such a big deal to deliver a web page on an internal IP via SSL… I can’t re purpose or buy another Pi or N2 until something really works, in a somehow useful manner.

Thank you, at least for reading this bitter stuff, if nothing else!


I have worked with a couple of different home automation systems. They main key, I have found, is to get community help. It is almost impossible to figure it out on your own.

I am fairly new coming back to HA after 2 years with a different system so I am learning again.

1 Like

So… the sticky post is a good read.

The problem is, you deleted the thing that wasn’t working, so we have nothing to work with.

- alias: Make it work dammit
  - platform: numeric_state
    entity_id: sensor.temperature_thingy
    above: 20
  - service: climate.set_hvac_mode
      entity_id: climate.cooling_thingy
      hvac_mode: cool

Something like that, probably

1 Like

Have you made a generic thermostat for the AC? Here is the documentation on creating one.

Generic Thermostat Home Assistant

Here is my generic thermostat however it is for a fireplace modified for A/C. I use a shelly device to turn on the fireplace. I don’t have an AC to test this on so you will have to check.

#Create a generic Thermostat for family room fireplace
#Use Temperature sensor located on Family Room East wall
  - platform: generic_thermostat
    name: Family Room Fireplace
    heater: switch.family_room_fireplace  # the entity that turns the unit on and off.
    target_sensor: sensor.familyroomsensors_air_temperature     # the sensor to determine activation
    ac_mode: true   # Added this for your scenario
    initial_hvac_mode: cool  # Added this for your scenario
    min_temp: 65
    max_temp: 78
    target_temp: 72
    away_temp: 74

This will create a thermostat that can be set in the lovelace interface just like a thermostat on the wall. The setting range for the thermostat configured above is 65-78 with the target temp of 72 and away temp of 74.

Hope this helps.

Note: This is placed in your configuration.yaml file.

Normally I have no qualms helping new users, and I have helped hundreds, but I have made it a policy to avoid those whose very first post represents one or more of the following:

  • Is a rant.
  • Expresses more frustration than any useful information.
  • Threatens to give up.
  • Refuses to read documentation.
  • Unwilling to supply critical information.
  • Doesn’t comply with the guidelines in the FAQ.
  • Their failure is the fault of everything except them.

All I can offer is what I tell others in the same situation:

Home Assistant is for hobbyists and requires a sizeable investment of one’s time and effort. It’s not for casual users and so you may wish to consider selecting something else or redoubling efforts to learn it.

I wish you the best of luck!

1 Like

Many new users want to do it themselves and reach a level of frustration before asking for assistance. Failing to do it themselves hurts their pride.

Please be a little more understanding. I agree about rants though.

Thanks for responding. @Tinkerer and @123 none of those apply, maybe kinda a small rant, but really no need to bash the newbies I was asking how would you recommend to get started… to start an AC unit as I am clearly doing something wrong, or something is wrong with my setup.

1 Like

Start with the automation docs, and the climate integration docs.

Then, ask questions - here or over on the Discord server. The more interactive you make this, the more we can help you.

When I was initiallt starting my journey into home assistant I found that the glossary was helpful to understand what the terms meant. I still refer to it often.


1 Like

I read those, the AC unit is fine, and manually everything works. Even as an automation, it changes hvac states, it shuts down, tried all kind of stuff; except for starting up < doesn’t work. Can’t figure out what to invoke as a trigger, tried everything obvious.

I listed behavior that serves as a disincentive for me (and possibly others) to rush to your assistance.

I purposely omitted one and that’s where the user characterizes any disagreement with their stated opinions as “bashing”. So, your post has that one as well.

It’s the first day at your new job and the way you ask for help is to first perform “a small rant”. When informed that’s not the way to solicit help, you inform them not to “bash” you. Can you see how that wouldn’t be starting out on the right foot?

Based on a quick forum search of “BRP069B45”, the results indicate it’s supported by a custom component. Is that what you tried to use?

1 Like

Here is how I would use the UI to set the automation. I don’t know how you named your entities.

My logic

Trigger: If my main floor sensor > 72 degrees
Action: Turn of the FR fireplace

obviously this is a fabricated automation.

Here is a screenshot of the automation.

Sadly, it’s really hard to help you. It’s not at all apparent what:

except for starting up < doesn’t work

Is the automation not running? Is the AC not running from the automation? Is the whale falling faster than the petunias?

To test an automation there’s three stages you can follow. Testing the action, the condition and action, and the whole automation:

  1. Use Developer tools ()-> States to find the automation, click and then push Execute. If this fails your problem is in the action: section, and details should be found in your log file
  2. Use Developer toolsServices and call automation.trigger on the automation with skip_condition: false . If the first passes but this fails then the problem is in your condition: block
  3. Use Developer toolsStates to find the trigger entity, click the name, then change the state (at the top) to something that’ll trigger the automation before pushing Set State. If this fails then the problem is with your trigger: section, or the automation is turned off (you can check that in Developer tools → States ).

You can also see this section in the docs and with HA 2021.4 onwards debug automations.

1 Like

You need to figure out “when do I want to turn the AC on?” - that is your trigger, and possibly your condition.

When the room is over 24 degrees.
When the room is over 24 degrees and it is daytime
When the room is over 25 degrees and someone is home
At 7:00 am during summer

We can’t guess what you are trying to automate, do tell us :slight_smile:

This model is not supported. See:

There is a solution in that topic. Install the older wifi controller which does still work:

So if you can currently control your AC from a thermostat card in Lovelace do not connect to the AC with the Daikin app and update its firmware or it may stop responding to home assistant.

1 Like

Tried something like that, this is what seemed like a good option to me:

And I do have a card and its controls, in the dashboard are working fine, there are also sensors for the simplest automation ever :slight_smile:
Also tried with different sensors in the trigger, tried with different actions (changing presets, hvac modes)
This is the code generated:

- id: '1625416471401'
  alias: Daikin_AC
  description: AC_Control_Daikin
  - type: temperature
    platform: device
    device_id: f9c4939f55a2c3b29341721af46814f8
    entity_id: sensor.daikinap84451_inside_temperature
    domain: sensor
    above: 20
  condition: []
  - service: climate.turn_on
      device_id: f9c4939f55a2c3b29341721af46814f8
  mode: single

Took a look at the post but I have the BRP069B45 controller, which seemed compatible, that is why I wrote, perhaps interpreted, that I didn’t buy something “better”. Was not blaming… anything really, was my decision, and that’s it.

Also it is weird in the way that I can control the AC from my dashboard, so HA talks fine and “everything” seems detected

Even more weird is that, if for example I set an automation to change modes, stop the ac, or other settings - it works. Except fort starting up, as I mentioned.

As you can see, the automation should be triggered at 20, but the card is greyed out (it changes blueish when it does), and the AC not starting.

Now, if I “RUN ACTIONS” in the automations page, the darn thing starts up just fine, so it is also able to start up. That’s why I am trying to set aside any diagnosis on my side, let the doctors draw their own conclusions :sweat_smile: Thought to start fresh, didn’t expect that many reactions, man this community is active.

So, you say the automation doesn’t work, but when you run the actions it then it does. That points strongly to a problem with the trigger.

You’re using a numeric state trigger (in a different form), so the temperature has to start at 20 or below, and then rise to above 20 for the automation to run. That has to happen after the automation is loaded (so, when you edit any automation, restart HA, etc).

Excellent! Don’t update the firmware in the wifi controller. In other words don’t ever connect to it with the official app as I think it happens automatically.

To finish my previous posts, sorry for the many screenshots, seemed easier to show the problem, here is the result when running the automation

In the logs I only have the occasional
2021-07-05 09:22:38 WARNING (MainThread) [homeassistant.components.daikin] Connection failed for but the router just shows that all connections are getting through… and controlling the start up works. By hand in dashboard and/or via running manually the automation