Help with zha, elelabs USB, zigbee and hass

Not knowing what issues you had with it–
maybe take another stab at hassio on a different SD card? see if that gets the Elelabs stick working

Thanks @cybergrimes - this is my fourth attempt on my third SD card (2nd Pi). :slight_smile: I’m really trying to eliminate everything.

I may revert back to trying it again, though. Really disappointed I can’t get it working. :frowning:

I am using the Raspberry Pi Shield on an ASUS Tinker board. It so far won’t work. I have been trying to disable my Bluetooth UART since the documentation says that it might need to be. When I run ls -l /dev/tty*, I cannot see ttyAMA0, which is what should come up for the elelabs device, according to the documentation.

Not that this helps, but am hoping that someone will see this and help us both.


An update on this: still no go! :frowning:

I installed hassbian on a brand new SD card, and plugged the Elelabs USB in…and it gets stuck on this line:

2019-03-02 03:06:00 DEBUG (MainThread) [bellows.uart] Sending: b'8160597e'

2019-03-02 03:06:00 DEBUG (MainThread) [bellows.ezsp] Application frame 25 (stackStatusHandler) received

2019-03-02 03:06:00 DEBUG (MainThread) [bellows.uart] Sending: b'015221575402629c7e'

2019-03-02 03:06:01 DEBUG (MainThread) [bellows.uart] RSTACK Version: 2 Reason: RESET_POWER_ON frame: b'c102029b7b7e'

Zero response from Elelabs. So, I’m going to give up and try and something else. Not sure what though.

I have working Elelabs RPi shield and if you want I can buy your stick and try it in my system.

I’m moving from RPi to “heavier” hardware and I would need to get Zigbee USB stick. In exchange, if your stick is working in my environment, I can send my RPi shield to you later.

I’m in EU area.

Has anyone managed to get this to work yet? Elelabs are dodging my emails and I’m really stuck.

Have it working with great stability since last update (0.86.1).

8 x sengled (light.sengled_e11_g13_)
2 x philips hue (light.philips_lwb014_)

running on a Hassbian with Elelabs zigbee shield.

First installs on Hass was very flaky, but the serial settings that came out of the box with last Hassbian version were actually fine besides disabling the bluetooth on the image before booting.

I’m going to give it another try, now that I’m on 0.89.2. But I’ve also ordered a Dresden shield that should arrive next week to try that. Might have to learn deconNZ…?

It’s almost like the universe doesn’t want me to have this up and running!

I got my Dresden Raspbee shield and have set it up in a separate Raspberry Pi with deCONZ running…and now it won’t detect my Heiman door sensor that was the whole reason for me doing this! Plus, the Yale lock that I was hoping to use over Zigbee isn’t even supported in deCONZ (as far as I can tell).


I give up. I think I’ll just get an Aeotec Z-wave stick, and some other sensors that work with deCONZ. I do appreciate everyone’s help, but I’ve ended up at a dead end I think.

@Hepokatti - may be worth a shot, although even when I plug my USB stick into my PC, I can’t test it to see if it works because the link to the Node test app on the Elelabs site is dead!

Any way I could test it before I send it?

I was able to get the elelabs Pi Shield to work on a Pi3 Model B. I had to start with a fresh install of Hassio, then changed the config.txt file as elelabs instructed per the instructions on the Tindie website. Disabling of the Bluetooth UART is required due to a conflict.

Thanks @treborjm87, but I’m using the USB stick, not the shield.

I even tried disabling bluetooth as per the instructions for the shield, but it didn’t make any difference. :frowning:

Did you ever get this working? I’ve foolishly gone and bought one and now I’m unable to get Home Assistant to talk to it.

Not reliably, no. In the latest versions of Home Assistant, it seemed to be identifying it better, and I managed to get it appearing. But I haven’t successfully got it working with any devices.

At the moment, I’m just using a separate Pi running Phoscon/deconz and a Raspbee. Works really well.

Hi I’ve a problem setting up my Elelabs USB zigbee.
It look like the symlink in /dev/serial/by-id between the serial device and the /dev/ttyUSB0 is not created
I should get
/dev/serial/by-id/usb-1a86_USB2.0-Serial-if00-port0 -> /dev/ttyUSB0
but I only get
it is not linked to /dev/ttyUSB0 any idea of what can be done to correct this ?
If I connect the USB zigbee device to another computer that symlink is created so it shoud be something that is preventing the symlink to be created

With the update to HA 0.113.0 Elelabs USB stick is running well

I ran into the same issue with an Elelabs USB adapter - managed to get it working by first adding the user home assistant was running under (Ubuntu install) to the dialout group, then using /dev/ttyS0 at 115200 baud.