Home Assistant Community

History graphs show weird line

#1

I just upgraded to 0.58 for a couple reasons and noticed the graphs on the history tab have an issue. The graphs draw the first entity in blue, and those that have a second entity with the same unit of measurement are drawing in red. However, now in 0.58 the red line is more of a filled box. The line is choppy and not connected and everything under the line is filled in with a light red shade. If a graph has more entities with the same unit of measurement, those are OK and draw correctly, it’s just the second entity that has a drawing issue. I checked the breaking changes and also checked what was changed in 0.58 and didn’t see anything obvious in the release notes. Does anyone else see this or is this a configuration option that changed?

0 Likes

Weird line graphs
#2

I can confirm this.Auswahl_055

0 Likes

#3

Me too. I first thought it was related to the new JavaScript but graphs also appear this way with old JavaScript and even after I deleted all history data.

0 Likes

#4

someone want to file an issue on GitHub for the project?

0 Likes

#5

Can you? I have no account.

I was also going through the open issues and wondering if this is connected to a issue with the recorder component, where values get not stored due to an error.

0 Likes

#6

haha, I don’t have an account either. The recorder issue is specifically why I upgraded to 0.58. They fixed the “vacuum” function of the database where it would fail and prevent any additional data from being recorded. See here: https://community.home-assistant.io/t/bug-recorder-stops-logging-events/31190/5?u=squirtbrnr

0 Likes

#7

In 0.58.1 the problem with the history graph remains.
At me it is the same as at OP, same is at my friend who is also using HA

0 Likes

#8

Filed an issue.

3 Likes

#9

Having the same issue. It always seems to be the second line. In all pictures in this thread, is is the second line that is showing weird behavior.

image

0 Likes

#10

Bumping the thread just to let people know that this was addressed in https://github.com/home-assistant/home-assistant-polymer/pull/665.

Looks to be in the 0.59 release at the latest.

0 Likes

#11

0.59 has been released. i found no reference to this issue in the release notes. can someone confirm that the issue has been resolved?

0 Likes

#12

Yes. After HA restart and browser cache refresh all is correct now.

obrazek

0 Likes

#13

It’s better for me but still not fixed fully. I’ve cleared history/cache and reloaded the page in Safari (only browser I use) and the first graph still has one of the shaded red lines, but it’s of an entity that has no business being on that graph. Also seeing the same behavior in the iOS app.

I checked my customize section and I don’t have anything for that sensor that would change its units and it doesn’t make sense why it is there or still shaded red. It’s a Nest sensor, so it’s built into the component and not a stand alone one. Best I can tell the sensor is actually a state sensor that just says what mode it is in.

EDIT: it has something to do with the climate component. I removed that from the history and the issue went away.

0 Likes

Weird line graphs
#14

The climate component will still have the second graph show as a stepped area graph, as that is a feature introduced by this PR. So if your climate graph is the one still showing the stepped area, that’s now technically per design. As far as I know, there’s no configuration option to disable that, but someone else may know.

1 Like

#15

I’m going nuts with this history graph. All good until a few days ago. Now not only am I seeing this line-issue, I have another sensor betting displayed, Armed Cam Count. Note: I even removed the armed_cam_count from my config, and removed all rows in the .db entities table for all three of these components (and cleared browser, etc,).
Where is this coming from?

System Health
arch	armv7l
dev	false
docker	false
hassio	false
os_name	Linux
python_version	3.5.3
timezone	PST8PDT
version	0.89.2
virtualenv	true
Lovelace
mode	storage
resources	4
views	7
0 Likes

#16

If you click the toggle editor in graph card config does it show any additional lines?

Or if you click top right three dots “configure UI” then hit it again for the Raw editor, can you find those lines referenced?

0 Likes

#17

No. I removed all references during troubleshooting, but history-graph in Lovelace continued to display it.
Anyway, I gave up on history_graph and went with mini-graphic-card. Very cool. The unwanted AQI sensors are no longer appearing in Lovelace.

However, if I click on that card to display the sensor, those other sensors are still appearing. Looked through the db and can’t see these entries (I even deleted event rows mentioning these no-longer-configured sensors). Wish I knew where this history data is saved.

2019-03-20_9-52-38

0 Likes

#18

Try looking at this issue and see if it could be the same issue you’re having.

If you’re on a Pi, the issue there seems to be with raspi-copies-and-fills v0.10 but upgrading to v0.11 (via apt-get update and apt-get upgrade) apparently fixes it.

0 Likes

#19

tboyce1, you rock. :+1:

Thank you.

Spent hours researching, but never landed on that post. Fixed it.

Gene

0 Likes