Home Assistance devices not exposed in HomeKit (everything is installed)

I’m happy to help. Can you set logging to true in homebridge’s config.json, restart Home assistant, then restart Homebridge, and then copy and paste the whole log output so that I can see it?

You can set logging to true like in this example:

"platforms": [
    "platform": "HomeAssistant",
    "name": "HomeAssistant",
    "host": "",
    "password": "yourapipassword",
    "supported_types": ["automation", "binary_sensor", "climate", "cover", "device_tracker", "fan", "group", "input_boolean", "light", "lock", "media_player", "remote", "scene", "script", "sensor", "switch", "vacuum"],
    "default_visibility": "hidden",
    "logging": true,
    "verify_ssl": true

I see the entity id is cover.dinning_room_shutter_level <== use this entity id in customize then homebridge will see it. Earlier homebride ask you to put the cover type because you put the name as zwave not cover. I think now if you put correct entity_id homebridge would be able to see without putting the cover type. But you can try put it in full first.

      homebridge_cover_type: rollershutter   <== what happen if you don't put this inside, and what happen if you put this inside.
      friendly_name: Persiana menjador
      homebridge_hidden: false

I already tried it prior posting my previous answer. I’m going to try it again but I’m pretty sure I tested that, once I spotted HA complaining about that exact string.

Please before start homebridge show your config in both customize.yaml and config.json

Also how many devices do you have approximately like apart from cover, do you also have switch, sensor, light?

To check if your homebridge run properly and the matter is only the cover. You should let homebridge see all devices first. Then add the cover to your homebridge later. to hide the cover first, homebridge_hidden: true from cover.
Normally, if you don’t customize anything, but you have set homebridge to be visible it should be able to see every devices that support in homebridge. So I suggest you hidden the cover first then run homebridge.

Hello marthocoo, and thanks for your help!
logging is set to true already. I’m just able to access the logs via the web interface. Not sure how to access them when ssh-ing in, as hass.io dockered configuration makes this complicated. I’ve posted above the relevant output that I see. Any particular log message you would want to see? happy to paste it here (would rather avoid pasting the whole log chunk).


here you go:

core-ssh:/var# cat /config/homebridge/config.json 
  "bridge": {
    "name": "Home Assistant",
    "username": "MYUSERNAME",
    "port": MYPORT,
    "pin": "MYPIN"
  "description": "Homebridge for Home Assistant",
  "accessories": [],
  "platforms": [
      "platform": "HomeAssistant",
      "name": "HomeAssistant",
      "host": "http://hassio/homeassistant",
      "password": "MYPASSWORD",
      "default_visibility": "visible",
      "supported_types": [
      "logging": true,
      "verify_ssl": false

Also how many devices do you have approximately like apart from cover, do you also have switch, sensor, light?

Now they all show up in the Home app, even the cover!! :slight_smile:

So far, I managed to roll up and down the cover. Now my problem is that, regardless of the option homebridge_hidden in customize.yaml, as soon as I set the global visibility to hidden in config.json, every device disappears from the Home app, even the cover (which as said is set to hidden: false).
It looks like I’m almost there. Thanks to everyone here.

Any ideas?

The visible of homebridge allow all the types to be seen in homekit without customizing in HA. So what you want to hide from homebridge can be set from homebridge side. Let say switch from homebridge is visible but 8/10 switches in HA you want to be seen by homebrigde. So just customize 2 switches to be hidden from HA.

Many many thanks for your patience and support. I discovered one can also use the option homebridge_visible and set it to true. Now everything is working the way I want. Many many thanks for your help again, I’m very thankful! :slight_smile:

1 Like

One additional thing. I have an AppleTV4 and my native HomeKit compatible devices are available on my iPhone when I’m away. Is it expected for Homebridge exposed devices to not be available when away?

If your native HomeKit devices are available when you are away then so will the Homebridge exposed devices.

How weird then. I’m away and can see one native device but not the exposed one. Maybe hassio is down back at home :slight_smile:

Just checked hassio and it is up, and so is Homebridge. I will pay attention to this when I get back home and update the thread. Thanks in the meantime.

Hi. I am using include, exclude list in Homekit integration. After I modify list in HA, restart is needed or not?