Home Assistant Cast

I have the same setup, but on a HP N54L Microserver. I tried a cast to my Gen 1 Chromecast and it worked fine with my own https URL. I’m not using NabuCasa yet.

Can I ask how you have things set up? I am using docker images of nginx reverse proxy with duckdns to access home assistant core via https but when I enter my url at the authorization website the authorization redirect simply times out when I’m on my home network. Interestingly the authorization website works on an external network but the login is automatically aborted. I assume that is a security feature of the home assistant cast api.

Basically I have Debian 10 with docker installed. Then installed HA in docker. I haven’t really done much with the cast feature since then the post you are referencing, so I don’t even know if it’s still working for me.

I’ve recently got a google hub max so making something to work on that is on my to do list, just not anytime soon unfortunately.

I think my issue is stemming from the fact that my url is not accessible from inside my LAN. I’m not sure why or how to fix it but that helps explain why when I attempt to authorize using the home assistant cast site it just times out.

Possibly your router does not support NAT loopback.

After looking into this it could be my problem. I can’t seem to find a concrete answer about my router (Linksys MR8300) supporting NAT loopback nor any settings for it so I am thinking the answer is no. With that said it sounds like I might be able to get around it by running my own DNS server in docker. I might try that. The alternative is to install OpenWRT firmware but my router is not officially supported yet.

Thanks for the advice!

Another possible workaround for NAT loopback instead of buying a new router is to install pfsense, pi-hole or DNSmasq

I am still as a question mark with this problem. Cast.show_lovelace_view is missing the history data. It used to work like charm, but not any more. I have tested with three different systems with and without Nginx (just a wild guess) but I just can not get it working. An example picture below:

Anyone, please - does it work for you? At least I can see couple other users in this thread struggling with this.

All around this discussion is a white beveled touchscreen running HA Cast. Please, folks, what is this one and do we have a list of cheap/preferable/good devices to use for HA cast? Thanks

I suspect you are referring to the Google Nest Hub.

Thanks! Looks neat and is actually even cheap but doesn’t seem to be mountable on the wall. Any other ideas for HA cast?

Can android tablets act as a chromecast receiver? I dunno.

Why are you so intent to use casting? Any recent enough android OS has a browser that will cope with the HA UI.

Have You find It?

Anyone can help me? Its being happening for a while , I cant change the views neither from HA cast nor thru call service , its being uselless using only one view

1 Like

As suggested above I believe I am dealing with a NAT loopback problem. Cast isn’t important enough for me to buy new networking equipment so I was trying to test up a DNS server in docker but never did get that working.

I wish Cast was not so complex to implement but maybe I will get it working someday…

I am struggling with this problem to.

Could it be that the Home Assistant Cast user do not have access to the database with the history data?

Can add that I am using the Nabu Casa cloud service.

My latest experience with this issue:

It works but it needs random number of restarting the core. From the top of my hat I can say that maybe around once in twenty restart lovelace casting starts to work correctly. And it continues working reliably until next restart. Right now my only solution to keep it running is to avoid core restart as much as possible.

Why - I just do not have the slightest idea?

1 Like

anyone can hel me how can I navigate thru the views? I used to use weblinks, but it looks like it´s not working anymore, I tried as scripts, calling cast service, but it works randomly not always change the views, anyone has any workaround?

Seeing the same issue on my Google Nest Hub using Home Assistant Cast. “Loading state history” for sensors never completes. I have also noticed that the calendar entries do not populate on the native calendar card. I have set up the NAT Loopback to make sure that is not the cause of my issues and it hasn’t helped. Would love some advice!


@jcbbas thanks! Probably saved me 30 minutes of finding out it’s just a button i needed to press…