Home Assistant Installation

I have reinstalled Home Assistant on my Raspberry Pi 2 and connected it via ethernet. I am able to access it via SSH but not at and http://hassbian.local:8123 but still nothing loads. I have waited for about 30 minutes. What am I doing wrong???


SOLVED BY @Kem down below

1 Like

Are you sure the IP is correct? Unless you locked it in your router it may have changed. I have found http://hassbian.local:8123 to be unreliable.

@silvrr I have checked and is definitely correct. Do you have any other ideas?

Ssh in to the pi and type:

sudo systemctl status -a homeassistant.service

(obviously making sure you use the correct name for the service in your environment)

Is the service running?
Are there any errors displayed?

This is what has come up

● homeassistant.service
Loaded: not-found (Reason: No such file or directory)
Active: inactive (dead)

OK, what did you call the service when you created it?

I’m sorry, what do you mean by what did you call the service when you created it. What service are you speaking about.

If you are on a hassbian install it would be

sudo systemctl status [email protected]


The service that starts HA for you when your pi boots?

Similar to…


This is the readout below:

[email protected] - Home Assistant for homeassistant
Loaded: loaded (/etc/systemd/system/[email protected]; enabled)
Active: failed (Result: exit-code) since Tue 2017-05-09 20:05:16 UTC; 7min ago
Process: 781 ExecStart=/srv/homeassistant/bin/hass (code=exited, status=203/EXEC)
Main PID: 781 (code=exited, status=203/EXEC)

May 09 20:05:16 hassbian systemd[1]: Starting Home Assistant for homeassistant…
May 09 20:05:16 hassbian systemd[1]: Started Home Assistant for homeassistant.
May 09 20:05:16 hassbian systemd[1]: [email protected]: main process exited, code=exited, status=203/EXEC
May 09 20:05:16 hassbian systemd[1]: Unit [email protected] entered failed state.

As per this video - https://www.youtube.com/watch?v=tCGlQSsQ-Mc I have just loaded Home Assistant onto an SD card and waited 5+ minutes to find that at there is no web UI.

Hmm…If you can SSH in and its responding its not an issue of nothing loading at all. Seems like the install got hung up.

Do you have config.yaml and a couple other files at /home/homeassistant/.homeassistant/?

if so try restarting the HA service.

sudo systemctl restart [email protected]

It seems like I do not have the /home/homeassistant/.homeassistant/ files

I have even tried to do this on another Pi and have reinstalled Hassbian onto another micro SD card. It seems like I have run out of options? What would you suggest?

Are you sure that your PI is communicating out to the web? It does need to download the latest version. I don’t think there is a version installed, the framework is there but without the initial connection it won’t be able to run.

Trying on seperate PIs and seperate SD card should rule out a corrupt SD card or PI issue. Have you tried re-downloading the ISO?

Do a

cat /var/log/syslog | grep home-assistant
cat /var/log/syslog | grep hass

via SSH should shed some light on the matter.

this may sound crazy but i was having the same problem installing a fresh image for my sister 10 minutes ago and i was able to access via ssh but not http://hassbian.local:8123 or via my ip so i did sudo apt-get update and sudo apt-get upgrade and reboot then everything work out now ever

1 Like

Thank you so much @Kem you have solved my problem.

your welcome

sudo systemctl start [email protected]

I had the same issues when following install on Raspbian as per here: https://www.home-assistant.io/docs/autostart/systemd/

The issue was in the path to the binary file:

had to be replaced by
After that validating with sudo systemctl status [email protected] the service is loaded and active