Home Assistant interface for Garmin's Connect IQ platform


#21

Nah, just an unfamiliarity with git. Should be open now. Sorry!


#22

Hello @alanf,
thanks for sharing your code :slight_smile:

I installed it on my Fenix 5s and it works like a charm, I will take a look at the code when I have time to see if i can manage to display the values of the sensors instead of triggering them :slight_smile:


#23

Good news! The ConnectIQ app has been updated to change how it requests information from HA, so no modifications to the HA configuration is necessary.

So I put it up on the CIQ app store: https://apps.garmin.com/en-US/apps/47bd4ae9-088b-4404-a299-5bb5f69e0470
Just edit the settings and put in your HA url, password, and desired group to show in the widget and it should be ready to go.


#24

Awesome! I downloaded the app, but how/where do I edit the settings? Can I do this from the watch or phone?


#25

You edit them from the widget settings on the phone


#26

thanks you works good for switch groups.trying to use it to work with a cover group. not sure if I’m missing something with the setup or just a limitaion.


#27

HI, thanks for the app. I tried to run it but with no success. I edited the widget:
Host: http://192.168.xxxx:8123
Password: xxxxxx
Visible Group: group.hassiq
Added some switches to the “group.hassiq”.
Synchronised and when i run the widget on garmin - nothing showes up. Only the Home Assistant logo. Is there anything more i should do ? My garmin is Fenix 5.


#28

It runs a ‘toggle’ command on whatever entity you select, or if it is a script, then it executes it. I will look at adding cover support, but since covers do not support ‘toggle’ at the moment, a workaround would be to add a script that performs the actions you want, and then expose that script to HassIQ.


#29

Hmm, I’d make sure your phone is connected to the same network that your hass instance is running on. If your phone can access http://192.168.xxxx:8123 just fine, then the widget should be able to too.

If you still aren’t having any luck, and you are interested I could walk you through getting the log from HassIQ and I could see whats going on.


#30

I revied alle the configuration, and found what i did wrong. I misspelled the group config in HA. Thanks - it’s awesome !


#31

This is awesome! Well done and thank you.

One thing I noticed is that I had to turn on the bluetooth on my Fenix 3. The wifi alone didn’t seem to be enough. Not a big deal.


#32

Thanks!

Yes, unfortunately Connect IQ won’t let you transmit data over wifi, it has to be through the phone bluetooth.


#33

Hi @Alan,
after trying with:
Garmin Connect App > choosing my Fenix 3 HR from the sync status cycle > choosing "Activities & App Management > Widgets > HassIQ > settings > then i can easily edit: Host/Password/Visible Group… that working with HassIQ widget on my Fenix :smiley:

Tks Alan a lot and really appreciate your work & help!
Trung


#34

I’m guessing this is the same reason scenes don’t work as well? Thanks for the suggested workaround.

I suggest adding something about the toggle requirement to the description in the Garmin store, just in case someone doesn’t think to look here first.


#35

I just got a new garmin vivoactive 3 and was really excited to try this out. Unfortunately I can’t get it working :frowning: I’m at home on my wifi with bluetooth connected. Setup hassiq settings on the watch as follows:
Host: http://192.168.1.80:8123
Password: legacy api password (from before we were forced to make individual user accounts)
Visible group: group.lights

Getting Status: 401 showing on the watch and when I go onto Hass.io (0.83.1) at the above host address it’s showing that there is a failed login attempt from the IP address of my phone. So, something is getting through but I guess my password is wrong? There’s no field to input username though, so I’m confused about how to fix it.

What am I doing wrong with this setup?


#36

A 401 is an “unauthorized” error. Open an incognito window on the device that is paired with your watch. Attempt to do a legacy login, and see if you get the same result.


#37

It works absolutely fine signing in with the legacy password on my phone :confused:


#38

So weird. I’m running on a VA3 and have had no issues. I am running through DNS, so maybe that’s the secret? Or should your URL be https instead of http?


#39

Hello! New to posting here but long-time follower of Hassio development.

I too am getting a 401 error when using HASSIQ - currently running Hassio with DNS and a DuckDNS URL with no problems with connectivity. I connect to my instance using https://[redacted]@duckdns.org (no port number necessary).

@alanf - I think the problem may lie with the new token system that was implemented a few versions ago for legacy logins. A while back I noticed all my Siri Shortcuts that interfaced with the Hassio REST API had stopped working - with similar 401 errors. Once I had created a long-term token in Hassio and used that token in the headers for the REST interface everything started working again.

I was wondering how development is going with the new auth system (username and password) as if this is nearly done then there wouldn’t be much point in implementing the token system, however if it is a way off, would you consider adding this token authorization to HASSIQ?

Thanks for all your hard work on this project so far, I replaced an Apple Watch with a Garmin after a week of using it and the only thing I miss was device control from the wrist - with HASSIQ it looks like that will still be possible!


#40

@alanf - Just looked through hassiqstate.mc - I’m not a coder but I note your comment about Garmin possibly not sending Authorization headers through correctly?