Home Assistant is making my PC non responsive

Who told you that?

I know lots of people run HA in a VM but I don’t know that I’d call it the easiest.

Actually the easiest is running it on a RPi via Home Assistant OS. You just burn an image to the SD card and away you go. And you don’t have any of the potential hardware issues.

1 Like

I’d call frequent SD card failures a potential hardware issue.

1 Like

True but that’s not necessarily a given and won’t be an immediate concern.

I ran my first install on a RPt3 for almost a year on the same SD card without issue before I moved to the NUC. That card was still fine even then.

And if you want to mitigate that then run it on a RPi3 from an SSD (I only say RPi3 because I haven’t heard definitely if the RPi4 can be run from an SSD).

Either way running HA from a image on a Pi is still way easier. It’s not necessarily better (for reasons we won’t get into here) but it’s definitely easier to get up and running smoothly without needing to jump thru the potential hoops needed to run everything in a VM.

I suspect supervised is easiest actually. Cut and paste a few command lines into debian.


Okay so update, tried to install a second HA on the virtual machine and it didn’t go well. For the first set up and this one i followed the same tutorial: https://www.youtube.com/watch?v=sVqyDtEjudk&ab_channel=TheHookUp

I’m thinking remove the VM completely and start again? I do have a backup saved that i pulled before hand.

If you are using ubuntu anyway, I suggest a supervised install. Installing Home Assistant Supervised on Ubuntu 18.04.4

1 Like

Interesting what are the benefits to this way over the way i originally did it?

Yes Rpi4 can be run with SSD.
I ran Rpi4 4Gb on SSD for a few months and then I migrated to Rpi4 8Gb on SSD a week ago and everything works fine.

1 Like

Update, tried uninstalling Virtualbox, used the orbit uninstaller to get what i thought was the last of it, downloaded it again, surprisingly it still detected its old self so used the installer to uninstall it then reinstalled it again, the extension pack and then the VMDK file and launched home assistant again… Once again it froze my pc. I tested to see if i could connect to HA using its ip address on another device and it doesn’t show an active connection.

I’m really shooting in the dark here, no idea what the problem is.

Tested A ubuntu machine on the virtualbox and it didn’t impact my pc much at all using the following tutorial https://www.youtube.com/watch?v=QbmRXJJKsvs&ab_channel=ProgrammingKnowledge so it seems to be related to home assistant.

I would say your home assistant install is up the wop (tech term there). It is not home assistant as such, it is likely a config issue.

I did suggest a supervised install. Easy on ubuntu.

I understand, that’s the next attempt if I can’t get this working. I took a photo of the log this time to see if it narrows down the issue https://imgur.com/a/Gf1UfcD

It id failing on networking. Try changing the network emulation in virtualbox.

Tried changing the adapter, also unplugged and replugged in my wifi/bluetooth card testing both unplugged and plugged in as i only brought that last week, just to rule it out. Tried a restore backup from before the 22nd as well. No dice. Think it might be time to move off virtual box and onto a Pi or something

I would agree a Pi (with HassOS) is WAAAAY easier.
Re: the SSD on a Pi4 - Ive been running that way for about 9 months (Note: This is Supervised, not HassOS)
It was really tricky to set up though with the uSD just acting as a boot loader and I wasn’t very impressed about the hoops required
Then RPF launched the stable boot loader (EFT switch) It then became a lot easier,
I’m now considering @kanga_who 's option of running a Pi4b with SSD on Debian, he always writes good guides and MORE importantly keeps them up to date - 5 stars in my book

Krispkiwi, youtube videos are terrible at keeping current, they always seem about 2 releases out of date and seem to cause more trouble than they are worth. Go to a reliable source


Just tried the install wit the latest virtual machine installation instructions from the home assistant website, still getting the same error. https://imgur.com/a/UtKaDrG A person on reddit has asked me to turn off the USB but I’m also getting a ““The usb controller emulation is not currently enabled on the USB page. This is needed to support an emulated USB pointing device. It will be enabled automatically if you confirm your changes”” error at the bottom for that.

Update, also tried an installation on my laptop, same error.

Hey everyone, big update in narrowing this down. I tested an ISP router to see if it was perhaps a network issue but related to my Unifi setup rather than anything in the VM settings and upon trying to launch when connected to my ISPs router, Home assistant worked. So there’s something in my Unifi settings which is causing this error.

Another update:
If I run a Ubuntu Desktop Server in virtualbox I’m able to run home assistant on that server however it appears to be a lite version with no ability to upload snapshots. I’m not sure why going through a 3rd party machine and then launching the home assistant on that doesn’t cause the error but having it straight on my virtual machine causes it unless I use my ISP’s router.

You can make it officially supported if you install it on top of debian and some other stuff needs to be adjusted as well.

1 Like

I wonder who flagged this ???