Home assistant not working since upgrade

I’m new to Home Assistant and recently upgraded my installation. Now, I can’t access the Home Assistant portal on port 8123. I’ve checked the Home Assistant observer on port 4357 with all greens showing, and add-ons seem to be fine. I’ve tried rebooting and another network port with no success.
I’m hoping someone can help me troubleshoot this issue.

  • Zimaboard generic x86 installation
  • Home Assistant OS version: 12.3
  • Home Assistant Core version: 2024.5.4
    Any advice on troubleshooting would be appreciated!

If you can get to the console command line prompt you can revert to 12.2 using this command

ha os update --version 12.2

I tried the downgrade, got an error:
“Error: ‘OSManager.update’ blocked from execution, systen is not running - startup”

Have you tried a full system reboot - not just a HA reboot?

ha host reboot

That’s for the help so far!
This is the result of a reboot, I get to cli on the board but it’s like the application is frozen during boot and won’t progress past starting up.

Some options I would try:

  1. Restore the system from a know backup prior to the upgrade

  2. Use the CLI to perform some addition checks and rebuilds (Home Assistant Command Line)

ha su repair
ha core rebuild
ha host reboot
  1. Boot in Safe Mode to see if the problem persists - If ‘no’ then it is probably a misbehaving integration (see tracking down misbehaving integrations); if ‘yes’ its a problem with OS or Supervisor and should be reported on GitHub.