Home Assistant Community

Home-assistant running on Raspberry pi 2 B+ with tellstick duo

#1

Hello everyone,

First off all i would like to thank the developers making this amazing software, you did a really great job i find this very useful! :slight_smile:

I’m quite new to the Home-assistant software and I’ve managed to set it up on my freshly installed raspberry pi 2 using the all-in-one installer kit. After the installationen i used http://download.telldus.com/debian/ stable main package with aptitude packet manager to install my tellstick Duo.

I used this guide:
http://raspberry.arctics.se/2015/05/03/uppdaterad-artikel-om-tellstick-pa-raspberry-pi/ (beware its in swedish :wink: )

The tellstick works with my configured devices i can switch on and off all devices using tdtool --on --off ID

I also configured the home-assistant configuration file under home/hass/.homeassistant/configuration.yaml with the following lines:

tellstick:
  signal_repetitions: 0

light:
  platform: tellstick

switch:
  platform: tellstick

When i log on to my home-assistant website all my switches has been loaded and I have the option to turn them on and off. However when i press the buttons nothing happens. So dug a little deeper checking the /var/log/daemon.log to see if something happens. And this is the message i get in the log:

> Sep 28 11:34:34 Homeassistant hass[819]: INFO:homeassistant.components.http:Serv ing /api/services/homeassistant/turn_on to 10.0.0.2 (auth: True)
> Sep 28 11:34:34 Homeassistant hass[819]: INFO:homeassistant.core:Bus:Handling <E vent call_service[L]: domain=homeassistant, service_call_id=3052436752-46, servi ce_data=entity_id=switch.edisonlampafonsterbradevardagsrum, service=turn_on>
> Sep 28 11:34:34 Homeassistant hass[819]: INFO:homeassistant.core:Bus:Handling <E vent call_service[L]: domain=switch, service_call_id=3052436752-47, service_data =entity_id=[‘switch.edisonlampafonsterbradevardagsrum’], service=turn_on>
> Sep 28 11:34:34 Homeassistant hass[819]: INFO:homeassistant.core:Bus:Handling <E vent state_changed[L]: entity_id=switch.edisonlampafonsterbradevardagsrum, old_s tate=<state switch.edisonlampafonsterbradevardagsrum=off; friendly_name=EDISON-L AMPA-fonsterbrade-vardagsrum, assumed_state=True @ 2016-09-28T08:55:07.164173+02 :00>, new_state=<state switch.edisonlampafonsterbradevardagsrum=on; friendly_nam e=EDISON-LAMPA-fonsterbrade-vardagsrum, assumed_state=True @ 2016-09-28T11:34:34 .783606+02:00>>
> Sep 28 11:34:34 Homeassistant hass[819]: INFO:homeassistant.core:Bus:Handling <E vent service_executed[L]: service_call_id=3052436752-47>
**> Sep 28 11:34:34 Homeassistant hass[819]: INFO:homeassistant.core:Bus:Handling <E vent state_changed[L]: entity_id=group.all_switches, old_state=<state group.all switches=off; entity_id=(‘switch.sanglampasovrum’, ‘switch.edisonlampafonsterbra devardagsrum’, ‘switch.ledtvbank’, ‘switch.leddatorskrivbord’, ‘switch.ledljusst akefonsterbradekok’, ‘switch.ledkubtvbank’, ‘switch.ledvitrinskap’), auto=True, order=1, assumed_state=True, friendly_name=all switches, hidden=True @ 2016-09-2 8T08:55:09.809663+02:00>, new_state=<state group.all_switches=on; entity_id=(‘sw itch.sanglampasovrum’, ‘switch.edisonlampafonsterbradevardagsrum’, ‘switch.ledtv bank’, ‘switch.leddatorskrivbord’, ‘switch.ledljusstakefonsterbradekok’, ‘switch .ledkubtvbank’, ‘switch.ledvitrinskap’), auto=True, order=1, assumed_state=True, friendly_name=all switches, hidden=True @ 2016-09-28T11:34:34.836249+02:00>>_
_
> Sep 28 11:34:34 Homeassistant hass[819]: INFO:homeassistant.core:Bus:Handling <E vent service_executed[L]: service_call_id=3052436752-46>**_

I don’t really know what to do from here, is there some option i have missed out on? Anyone else gotten this error before?

With kind regards,
Johan

0 Likes

#2

Might be to do with tellstick repitions being 0. Try changing to 3 … as I currently have but I’m going to actually change this to 6 later as I’m getting some timeouts possibly due to distance from tellstick.

Restart and hopefully that works :slight_smile:

0 Likes

#3

I totally forgot about this post. But indeed Leebejeebee, That was the solution. Thank you for the answer :slight_smile:

0 Likes

#4

Glad you got it sorted pal

Just out of curiosity, are all your sensors showing up correctly? Having issues with mine showing up randomly along with some other people by the looks of it.

Going to rename them to see if this helps as last resort

0 Likes

#5

Yes all my switches from nexa are showing up. But my sensors are z-wave which is abit different to setup, but they are showing up all fine. What type of sensors do you use with the telldus protocol? Have you defined them in the tellstick conf?

Sometimes the naming can be a bit tricky. The names you give them in telldus arent always the same in HA. So check out the webinterface and see what name exactly they are given in HA.

0 Likes

#6

Don’t suppose you are running a fresh install? I can’t for the life of me get telldus reinstalled. Can’t find raspian jessie, only the new 'stretch which isn’t playing nice with some dependency libconfuse0

0 Likes

#7

I used this guide a long time ago: http://elinux.org/R-Pi_Tellstick_core

All though you will need to change the version when downloading the software with wget, because that guide is old and a newer version is prolly out there.

//Johan

0 Likes

#8

Any luck? I have the same problem with libconfuse0.

0 Likes

#9

I think I have the jessie isos stored on my server if there isn’t a quick fix using stretch. Shoot me a PM if you end up needing it. I should have regular and lite both stored.

0 Likes

#10

No sorry, didn’t have any luck. Got frustrated and ended up getting a rmpro. Have it setup now the way I had previously bar the temperature sensors.

Hue motion sensors have temp so used this sensor as a workaround.

Hopefully someone organises a git thing for it as tellstick stopped supporting it. I’ve no clue about this though

0 Likes

#11

I managed to build it using a beta version I found a reference to here: http://developer.telldus.se/ticket/473#comment:2

The steps I used was the following:

wget https://s3.eu-central-1.amazonaws.com/download.telldus.com/pool/main/t/telldus-core/telldus-core_2.1.3-beta1.orig.tar.gz
tar xvf telldus-core_2.1.3-beta1.orig.tar.gz
cd telldus-core_2.1.3-beta1
sudo apt-get install cmake build-essential
sudo apt-get install libconfuse-dev libftdi-dev
cmake .
make
sudo make install
sudo ldconfig

In order for telldusd to start automatically at boot create the file /etc/systemd/system/telldusd.service with the following content:

[Unit]
Description=Tellstick service daemon
After=multi-user.target

[Service]
Type=forking
ExecStart=/usr/local/sbin/telldusd

[Install]
WantedBy=multi-user.target

Then run the following commands to start telldusd:

sudo systemctl daemon-reload
sudo systemctl enable telldusd.service
sudo systemctl start telldusd.service

Edit: adding steps for automatic start of telldusd, typos, update after comments

0 Likes

Tellstick duo on Raspian Stretch?
#12

LeeBeejeebee, trying libconfuse1 instead of libconfuse0. I recently did a clean install of a RPI3 with stretch. Worked fine using the latest telldus-core release. Just download it from

http://download.telldus.se/TellStick/Software/telldus-core/telldus-core-2.1.2.tar.gz

Unrar it,

Read the README file in the unrared folder. Follow the instructions.

See this guide! as ref

According to the guide, in release 2.1.2 there is no need to create a service file for telldus. Just compile and you are done :slight_smile:

0 Likes

#13

Legend. Will try this later tonight. Cheersssss

0 Likes

#14

I cannot get 2.1.2 to work, I did still need the beta release I pointed out. The comment about not needing the service file is true if you do not want telldusd to automatically start at reboot or if you are not running a debian-based system after 8.0.

0 Likes

#15

Jorkar, followed your guide and got the following:
● telldusd.service - Tellstick service daemon
Loaded: loaded (/etc/systemd/system/telldusd.service; enabled; vendor preset: enabled)
Active: failed (Result: signal) since Thu 2017-12-07 16:43:13 +04; 2min 41s ago
Process: 9055 ExecStart=/usr/local/sbin/telldusd (code=exited, status=0/SUCCESS)
Main PID: 9056 (code=killed, signal=ABRT)

any suggestions

thank you

0 Likes

#16

Thank you. Fifth guide I tried but the one you linked that AndreasAhrens had actually worked!

0 Likes