Home Assistant shuts down without reason

Tags: #<Tag:0x00007f739159f220>

Hello,

I recently moved my installation from a server to a raspberry pi 4 due to the deprecation of the docker installation method. I also moved homes physically. Upon moving I got my Home Assistant back up and running with my backup. For some reason, it shuts down after about an hour (as my best guess) for no reason that I can see at all. I don’t see anything problematic in the logs, but to be completely honest I’m not sure I’m looking in the correct place. I do see a couple errors regarding an integration I have, but I don’t believe that should cause the OS to shut down and it would just prevent that integration from working. The only way to get it running again is restart the pi, which it does successfully every time.

Please let me know where to get logs for more information and if there is any ideas on why it’s shutting down.

What power supply do you use for your RbPi 4 ?

The one that came with the bundle. Amazon says the output is 5V 3 amp. Temp never gets above 50 degrees.
error1 error2

I did restart last night and got the three errors in the images I attached.

Are you running off an SD card or SSD? Maybe your SD card has a corruption.

Can you SSH into the pi when HA stops? If so try running “sudo docker ps” and see if the homeassistant docker container is running. You can restart it using its ID eg “sudo docker restart afh345ghar"

I run my Pi4 off an SSD and it’s rock solid so it’s strange that you are having issues.

I’m using an SD card and Hass OS, not docker. I can’t SSH into it when it goes down. I have tried multiple brand new SD cards.

Can you ping the Pi when it fails? When it is working do you have enough space on the SD card - maybe it is full and causing it to lockup.

The “docker installation method” was never deprecated. It was Home Assistant Supervised that was intended to be deprecated but then that decision was cancelled.

It’s vital that you use the correct terminology to avoid confusion. For example, there’s no official term called “Hass OS”. You are probably referring to “Home Assistant OS” which is a recommended installation method. Also, saying it’s “not docker” can also be confusing because Home Assistant OS actually uses docker. I believe you meant to say your installation method is not Home Assistant Container.

For future reference:

Home Assistant Installation Methods

I can not ping it. It is a 64GB SD so I don’t think its full. I barely have any integrations, devices, etc.

Okay. Probably could have been inferred that I meant Supervised was being deprecated. My understanding from what I read last was they were just delaying deprecation due to community input.

Hass OS was my shorthand for Home Assistant OS. Also this.

I’m not actually using docker myself when I use the Home Assistant OS method, so I would think it would be fair to say “I’m using an SD card and Hass OS, not docker.”

Sounds like the others were able to understand though :slight_smile:

The link you posted isn’t referring to Home Assistant OS so your shorthand actually used an abbreviation for entirely different part of the Home Assistant project, namely its custom operating system.

That link you posted is for the December 2019 release of the project’s custom operating system. That’s seven months before the recent renaming of hassio to Home Assistant OS. In a nutshell:

HassOS == Home Assistant Operating System != Home Assistant OS

That’s why it’s important to use correct terminology.

The fact that I and others understood it doesn’t justify its usage.

This forum’s content would become far less useful if everyone chose to describe things using their own made-up terms. Searching for a particular topic would be compromised if everyone avoided the official terminology and used made-up terms.

If you have a spare SD card why don’t you load a very basic install of Hass OS but don’t restore any of your config and see if this remains stable.

You can restore bit by bit and see if it remains stable as you build up your config.

It’s a long way to restore but as you have no access at all when it locks up you have little choice.