Home Assistant Supervised: “You are running an unsupported installation” and Debian version

I am running a Home Assistant Supervised installation on a small PC with an AMD E350 APU since June this year. I did the installation following this web page: Installing Home Assistant Supervised on Debian 10, and it appears to be running fine.
However, I just found out that there is a warning shown on the “Supervisor → System” page:

This links to this pop-up message:


And that “OS Agent” links to this page:

I don’t know how long this warning is already shown, but at least it was not the case for the first months.
As far as I know I do not have any further issues with Home Assistant at the moment.
As I understand it, the OS Agent is a new tool that has been added in April this year.
What exactly is this OS Agent doing?

On the HA Supervised on Debian page it currently is shown that the OS Agent has to be installed as well. This was not yet the case back in June. As far as I know I did not install the OS Agent in June, and this is the result of a gdbus check:

~$ gdbus introspect --system --dest io.hass.os --object-path /io/hass/os
Error: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name io.hass.os was not provided by any .service files

Are there any real issues or disadvantages of not using the OS Agent?
And can I still install the OS Agent now to solve the issue?

Another issue is that the currently supported version for the Supervised installation is Debian 11, and back in June it still was Debian 10.
Does it have any advantages to upgrade to 11, and if so, can this be an upgrade in place keeping all my current data and settings?

1 Like

You have to upgrade to Debian 11 by the end of December, or your installation will be unsupported. And yes an in-place upgrade is possible, without losing current data and settings.
See the topic you linked above for upgrade instructions.


The guide you’ve linked has been updated to help you install OS Agent. Follow the guide.

Thanks for your answers Francis and Jason.
But I am still not clear about what the OS Agent exactly is doing, and it looks like I am not really missing anything at the moment in my current installation?

It’s a requirement of a supported installation. By not installing it, you may not be able to update HA in the future.

Takes 5 mins, up to you.

if you really want to know what os-agent is doing, you will have to look at the source-code on https://github.com/home-assistant/os-agent.

Thanks again Jason and Francis.

It’s a pity that the info about the OS Agent remains a bit vague on the informational pages, but, although I am not at all an experienced coder, I will have a look at the source-code.
Just to be sure: I can already install the OS Agent now under Debian 10, and upgrade to Debian 11 later this year, right?

Yes you can.

Thank you Alfred, uh, sorry, Francis :wink: :+1:

Thanks for the guide and the help! Worked flawlessly!

Today I had some time to check-out the OS Agent source-code on GitHub, and as far as I understand it (with my limited coding knowledge) this agent (running on the host OS) provides access to the host OS storage from HA, using the freedesktop.org tools.
If this is wrongly described, then please correct me.

I successfully installed the OS Agent on my Debian 10 host, following Section 3 of this guide:

The only issue I had with this is that I needed a "sudo" for the “dpkg” command as well.
So the complete install for version 1.2.2 of OS Agent was:

sudo wget https://github.com/home-assistant/os-agent/releases/download/1.2.2/os-agent_1.2.2_linux_x86_64.deb
sudo dpkg -i os-agent_1.2.2_linux_x86_64.deb
sudo reboot

All is fine now: no more error message :slightly_smiling_face:

Since I installed OS Agent, my CPU temperature has increased by almost 20 degrees. Has anyone observed anything similar?

Update: 2021.10.3 solved the problem.