Home Assistant Yellow installation

thank you for your replies, it has worked well for me. The only thing is for the moment, with a raspbian os I cannot use the zigbee module, and the led of my yellow is always red.

The red led is always on when the yellow is powered on, see Home Assistant Yellow Guide (home-assistant.io)

A 1TB SSD is not overkill in my opinion, looking towards the future. My 1TB is already using 20% including all backups. I however do everything with my Home Assistant instance. When there would be over-usage (wear leveling) of the SSD, I still will have 80% room left that can be used to store data unaffected by wear-leveling. It’s also not good to fill a SSD up till the maximum, so that keeps also some room available for when things go haywire (like logs going crazy)

I use a 256GB SSD which is now filled at 2%. I keep to the last 7 days backup on the Yellow locally.
Furthermore, I keep last 31 days backups on my remote NAS just to have offline (remote) backups in case the SSD is failing completely.

Am considering ordering a 1TB SSD and running a Plex server on the HA Yellow. Does anyone have any experience of this?

There are several Yellow users with 1TB M.2 SSD (e.g. Samsung 970EVOPlus), however I’d think carefully about the wider impacts of filling HASS with media.

If you use HASS as a media store, it will include ALL files in backups (and think how long that will take for each release). Others have asked about excluding folders, but I’ve not seen a solution (e.g. exclude /media).

Many releases ago, I added a couple of albums worth of audio as a test of the original media player.
Not long after, restoring a backup failed.
I had to untar the TGZ, manually remote the media files, and re-create the TGZ for the backup to work.

You could create a bash script to process HASS backups and strip out media files automatically, but that needs working space.

Backups are usually small compared to available disk capacity, so working space for restoration is not an issue - until you fill /media up to a significant percentage of your disk.

Hmmm, useful. Thanks.

I wonder about partitioning some of the SSD then, and just pointing the HA Plex Server integration at that partition?

If you’re using HASSOS, I doubt that’ll work without a load of effort (and HACS extras to get enough access).

Some folks use bare RPiOS + Supervised, but there may be some issues with Yellow hardware drivers - suggest research is needed.

The media_source: setting exists if you can get a partition mounted somehow.

Seems this is the “My Yellow isn’t working” thread…

I have the Yellow w/ Pi 4 and eMMC, non-PoE (“sorry, only PoE version :(”), and no SSD. All it does is stare at me with a mocking red LED. No blinking yellow, no flicker, nothing but solid red.

I tried escalating levels of pressure in seating the CM4 to no avail, and managed not to snap it in half.

I tried installing the OS from a USB key, nope, all red, all day.

Followed Option 2 from the OS reinstall page and saw the green LED along with the RED while it re-imaged. I was hopeful but after unjumping everything… still… nothing.

I have a M.2 SSD laying around that I’m toying with jamming in there just to collect all the troubleshooting tips but I’m at the end of my troubleshooting.

I have been running HA from an Antsle Nano via Docker and that’s working great but I was pretty stoked on being able to run the OS and having all the fun bits onboard.

Option 2 is definitely the way to go. I could not even get the usb stick thing to work one bit. When you do option 2 and install home assistant yellow from rasp pi boot, make sure to put the jumpers back to the original position. Plug in the Ethernet then plug in the power and wait. Should see yellow blinking and then if you see a solid yellow for a couple seconds that’s good. Then it should start heart beating yellow and doing the installing process. Then the LEDs either shut off or its supposed to be solid red to indicate its done. Once solid red, unplug device form power and Ethernet, then replug Ethernet and power and wait… see if that works?

Just to be useful to other late-night-impulse-buy folks out there, pay attention to the fact that Yellow supports only NVMe M.2 SSDs.
I just installed a SATA III SSD, it fits, it powers up with a nice blue LED… but…

Well, now I have to decide what to do with this 250 GB SATA disk.

…and order an NVMe one…

Hi Guys,

I have a WD SN810 NvMe SSD - 512gb, I have plugged this in and installed HAOS but i facing the same issue when i try to move data disk.

I tried formatting the SSD to ExFat and try mounting again but it doesnt seems to detect. Is there anything else needs to be done to detect the SSD?

I have the same problem. The disk show up under " All Hardware" with the DEVNAME /dev/nvme0n1, but it is not found when I want to move the data disk.

Found out the hard way that WD SN810 is not supported, and used a different brand SSD and it works. Now i cant seem to get ZHA working…

I installed a wd red ssd. When it is in the yellow, the yellow doesn’t start home assistant anymore. Only the red and the green light are constantly on.

Is picking a ssd kind of a lottery?

What can I do? I already sent back a ssd because I thought it was broken.

Looks like the WD Red M.2 drives are SATA. The HA Yellow only works with NVME M.2 drives.

I have the nvme m.2 :slight_smile:

Is it possible that the yellow boots from the new and empty ssd? Because with the ssd installed, it doesn’t work anymore.

1 Like

Good question. It depends on how the boot order is configured in the CM4. I had to change mine to boot from the NVME drive first. :thinking:

Thanks for your answer. Do you know how to change the boot order?

Hope this may be of help… Raspberry Pi Documentation - Raspberry Pi hardware