Homeseer HSM200 Zwave LED On/Off and Color Control

Tags: #<Tag:0x00007fc3ea39c500>

Thank you both for sharing the workaround to get these sensors working.

  1. I cloned the ha core and made the edits as you both suggested last night,
  2. Copied the zwave folder into the custom_components.(I renamed my component hszwave),
    3.Added hszwave: into my configuration.yaml file
  3. Checked config and restarted and there was a light entity! (Okay, actually it showed up after my second start because I had to remove the “+” on the light file after my first restart which thankfully showed up in the log file).

You are right something affecting the service callI noticed right way I had to toggle the light entity switch twice before it turned on last night. And this morning, I had to turn it on and then select a color before it illuminated. I was able to do a quick motion detection automation that turns the LED Red with the light.turn_on service with one action only; but the LED previous state was Red, so that might have allowed it to work with one service call. I’ll make sure to add a repeat service call for good measure.

I also struggled with this.

But good news this seems to be fixed z-wave JS. I can easily set the led light for this motion sensor with my automations using the call services.light option.

Side note I did remove the sensor from my z-wave network and re-added it after converting to z-waze js. Not sure if that is required or not.

But so glad to now be able to easily use these sensor to there full ability.

Thanks for sharing your success with these on z-wave JS. I’m glad to hear it works by default now. I’ve been holding off on migrating to z-wave JS for several reason, but the fear of losing this feature was a top one after the help I received to get it working. Time to get my zwave network listed I guess.

Hey jwin32,
I just setup z-wave JS and can’t seem to get the HSM200 sensor setup correctly? At one point I was able to set color using a door sensor (mailbox notifier project) but I am having issues with motion reporting, it always shows a Detected status. I tried re-adding the device same thing. Another thing I noticed was after power cycling the sensor it would respond with the usual red indicator for motion but then that stops working after I set a color? I’d appreciate any advice, I’ve tinkered with HA for a couple months but z-wave is very new to me.

Hi @MrGiovanni,

I actually haven’t made the switch to z-wave JS yet, I was just commenting on how relieved I was to hear from @cass2115 it was working. I guess I assumed the post meant it worked by default with the new integration. Sorry to hear you aren’t having immediate success.

I did not see Command Class Color listed when I looked at the z-wave JS Command Class conversion status (which was the custom integration edits frescoat had provided originally to get the light to work marked as the solution), so I was initially skeptical if it would work in z-wave JS by default. There is a Color Switch row now, but I’m not smart enough to know if these are the same. You could always try removing and including the device again suggested, but for the specifics of how to get it working you might check with cass2115. I’m curious as well, since I relied on everyone else’s smarts to make it easy for me to copy and paste to get it working.

1 Like

I have a few HSM200 devices and one EZM. The appear physically the same, except for the EZMultipli logo on the EZM. In Z-Wave JS the HSM200 devices now have a light entity that I can use to control the indicator, however the EZM does not. Interestingly, the HSM200s show brand of EZMultiPli and firmware 2.2, the EZM shows firmware 1.10. When I get time I’ll look at the Z-Wave JS code and look into if the EZM needs a firmware update or what but it might be a while before I can do that so hopefully someone else can get it working sooner.

Sorry I have been busy with work lately. But let me see if I can help shed some light to this situation.

To get this to work with my automation for changing the light red when my garage door is open this its the action.

You can also manually set the color of the light with out automations. By clicking configuration then integrations then scroll down to Z-wave JS then click on devices. This brings up all the zwave devices. Then click on the hsm200 device. Then under the entities section click on the entitiy with the light bulb beside it. Once the settings menu comes up. Click on the hamburger menu (top right of the settings menu). Now under the detail menu once you slide the brightness level up the color wheel will come up and you manually set the color to what ever you like.

Hopefully that helps.

Sorry I tried to post more images. But limited to one. If that was to confusing let me know and Ill try to add more images.

Ah okay my mistake, thank you for getting back to me @jwin32

I will try removing my two zwave devices and start from scratch

Thanks for the extra info @cass2115 and @claytonjn … I’m going to start over and setup my zwave network again. Also removing my attempts with automations trying to figure things out.

My only devices so far are EZM HSM200 and an Ecolink door/window sensor. This shows up under zwave js as 3 devices (including usb controller) and 19 entities? I somehow duplicated entities and some are showing as disabled? Lol oh boy I dun goofed pretty good…

Hey everyone. I am just finding this thread today, and have a couple of these devices identifying as EZM in my Zwave JS integration. I do not have any light nodes appearing in my entities. I am unclear whether I am out of luck based on the last message from @MrGiovanni .
I’d love to integrate the RGB light if possible. Can anyone comment whether I would be able to?

Thanks!

When I said light entity this is what I meant.

To get to it. I go to configurations, intergrations, down to z-wave JS, then devices, then the hsm200 device.

Then go here.

then

Turn the brightness up and you’ll see the color wheel pop up. Set the color you would like as well as the brightness level to your what you desire.

Again this is to set the device manually. Which I don’t really do. I use the automations as outlined in my first post to set them based on certain conditions.

But doing it this way will prove that everything is working properly and that the color can be assigned.

Hopefully that helps. Sorry for so many post… wouldn’t let me do it in single post.


Sadly, it appears as though I have the devices mentioned by a previous post. No entity of that type with mine. Out of luck I suppose.

Hmmmmm? I see. Have you tried to re-add the device. I also remember somewhere reading that when devices are added into Z-wave JS they must be “activated or toggled” so that JS sees them. When I first plug in my HSM200 and press the include button the led lights up blue with motion. ( I guess to let the user know its is detecting motion and working properly) It only does this for about 30 secs or so then it stop doing it. Maybe when it does this it adds the light entity. Does your device do that? Has it ever done that?

One other note my device is Homeseer brand, on firmware 2.3.

I noticed that yours is not the same brand and the firmware is 1.8.

Not sure if that has anything to do with it. Nor do I know how to update the firmware.

But it could be worth checking out.

Re-adding is worth a try. I have migrated from from each of the other Zwave integrations to JS, so who knows. I noticed the difference of brands, and that was my primary concern.
I am also curious if I could update the firmware on these somehow. More reading to do I suppose!
Thanks :slight_smile:

No joy. Comes back exactly the same way. Must be a different version of the product entirely.

Doing a little digging myself. So it does look like there are two different versions of the hsm200. V1 looks very similar to v2… except version two has a screw tab on top like below. Which is exactly what I have.

V2 lastest firmware is 2.2

V1 latest firmware is 1.10

I noticed that your is 1.8 so you have v1 and can update to 1.10. That may or may not help. If it doesn’t help then looks like you’ll need a v2.

Here is a forum post talking about it. Luckily there is a link to firmware 1.10 for v1 in post #9 if you wanna try it out.

https://forums.homeseer.com/forum/homeseer-products-services/homeseer-z-wave-products/hsm200-multisensor/1282342-firmware-configuration-parameters

That’s all I’ve got for now.

1 Like

My EZM (v1) is on 1.10 and the light entity isn’t created. My HSM200s (v2) are on 2.2 and do have light entities. I could be mistaken, but I believe they both utilize COMAND_CLASS_COLOR and I’m almost positive I’ve controlled the indicator when paired with different Z-Wave controllers so it should just be a matter of some compatibility changes being made to ZWave JS.

Any updates? I’m porting things over from SmartThings where I was able to control the color of the light. My EZM v1 is on 1.8. Just connected to zwavejs2mqtt and see color switch config, but sending values does nothing and HA doesn’t see it as a light entity.