Honeywell Total Connect Comfort (US) with TH6320R1004

I have two zones controlled by two RedLINK thermostats TH6320R1004. I added the Honeywell RedLINK Internet Gateway because I was hoping to control the temperature and the fan mode from the Home Assistant.
The first thing I discovered was that Honeywell just doesn’t support the fan control with this setup.
The second problem seems to be related to the HA integration note:

“There is a “known” issue related to setting the temperature from Home Assistant with some thermostats. If your instance receives errors when setting the temperature above or below some value, go to the Honeywell web page and set the temperature to the max or min for the mode you are using, then adjust from Home Assistant.”

I have not been able to successfully set up the thermostat control. The only way the HA seem to change the programmed value is if I go to the thermostat and change the setting. Then I can control the value from the HA, but only until the next time period programmed in the thermostat.
That essentially makes it useless.

Does anyone know how to make it work?

Honeywell / Resideo told me that the only RedLink based thermostat that would support fan control would be the Visionpro 8000. Howerver, that isn’t in the list of supported hardware in Honeywell Total Connect Comfort (US). Does anyone know if that combination would work?

Did the integration you set-up add climate entities. My older Honeywell did, and I automate thru those.

Yes, it did:

I have two entities:

Those are your control points. Use the climate entity to set your temp, change modes, etc.
Climate - Home Assistant.
You can look thru my config to see how I use it.
GitHub - SirGoodenough/Home-Assistant-Config: My HA Configuration... This is what I run for production in my house..

Please consider marking my post with the Solution tag. It will automatically place a check-mark next to the topic’s title which signals to other users that this topic has been resolved. This helps users find answers to similar questions.

For more information about the Solution tag, refer to [guideline 21 in the FAQ]{How to help us help you - or How to ask a good question}.

Lots of great examples! Unfortunately, I cannot identify anything that would solve my problem.
I can control the thermostat, but only after I manually change the programmed value. For example the thermostat is programmed to change to 20’C at 5 pm. The HA cannot change the temperature after 5 pm until I push a button to change the setting to 19.5’C. After that the HA has control until the next thermostat program time.
Perhaps it has something to do with the ‘permanent_hold’, but changing it to ‘false’ doesn’t seem to help.


I have a schedule that is always running.
I can at any time change the temp from the native phone app or the thermostat card in HA or HA automations. The scheduler will resume control at the next scheduled change. If I have changed the temp in HA, I can go to native phone app and have the schedule resume.

So that is all working like I think it should work. I’m never locked out.
Your thermostat card looks a lot different than mine, so don’t know if that’s related. I have the standard HA one.

I just use a Mushroom card to save space. No functional impact.

So after posting the standard thermostat I realized I forgot to include the ‘Climate HVAC modes’ that you show and when I went to correct it, I noticed another feature available - ‘Climate preset modes’.
After I added that feature I tried to select ‘None’ and received this error message: ‘Preset mode is not valid. Valid preset modes are: none, away, Hold.’ - go figure.

But when I tried ‘Away’ it actually worked and let me change the temperature.
‘Away’ apparently corresponds to the Hold button on the thermostat. It suspends the thermostat program and lets me change the temperature from the HA.

It’s not a perfect solution, but I will call it good enough. Thanks for your help and inspiration!


Was having the same problem… Thanks P2-3d