Hosting HAOS in ProxMox - Can't connect

I have just installed ProxMox and installed a VM from the latest .vmdk image. Here

The VM boots up and shows an IP address on the HA home screen. However, I cannot connect to HomeAssistant. I have tried with IP:8123, and http://homeassistant.local:8123, but it won’t connect.
I am trying to connect from my linux desktop computer. I can ping the IP that is given.
I even tried reaching it from the machine hosting proxmox and I cannot connect.

I’m wondering if there is a better installation rather than using the .vmdk ?

Also, I have run the network upgrade command from the HA home screen to manually set the IP, but It doesn’t work.

I am pretty frustrated, and wonder if it’s the proxmox or the HA vm that is giving the problem.
Any help would be appreciated.
Thank you.

If I remember correctly Promox requires the qcow2 when setting up the VM. When I set this up for a friend of mine, I followed the steps in this post: Installing Home Assistant OS using Proxmox 7 - Community Guides - Home Assistant Community (

If you dont want to use the script, then you can follow the steps outline in this post: Install Home Assistant OS in Proxmox manually (it’s not that difficult) : homeassistant (

Thank you. I was unable to get qcow2 to install. There was a step (that I can’t remember now) that returned an error no pve/data found. I think that the qcow2 file expected a particular data / disk setup that I didn’t have. So, that’s why I went to the vmdk route.
I am downloading an ubuntu iso now then do then I’ll do the manual install.
Appreciate the help.

Just to close things out.
I finally got the issue worked out.
it turns out that I did not understand how the network devices in ProxMox worked.
Once I got the network device configured properly, I was able to connect to HAOS.
Thank you for billyjoebob999 for the help.


I’m having the same issue. Can you share what was the configuration you did?


Hi Mike, are you using a VM with HAOS?
How do you connect to your HA webUI? (which URL are you using)
Check the console to see if you have the IP address right.