How delete false duplicate of binary_sensor

I have two binary sensors. I changed and renamed them several times. Now it are like this:

  - platform: ping
    name: "ping1_is_available"
    count: 5
    scan_interval: 60
  - platform: ping
    name: "ping2_is_available"
    count: 5
    scan_interval: 120

At one point, I noticed there was a duplicate of ping2_is_available in Overview.
In Entities, I also see two: one have Entity ID = ping2_is_available and second have Entity ID = ping2_is_available_2. I cannot remove this duplicate from Entities, but it is also not in my .yaml.
How do I delete this false duplicate of binary_sensor?
When updating the HA version, this duplicate disappears for a while, but after 10-15 minutes it appears from somewhere again.

You should be able to delete it in the entities list. If you select it and click the gear wheel then there is no delete Button?

All binary_sensor that are defined through yaml in Entities are displayed with Status Read-only.
If you try to do as you write, there will be a message:

This entity ('binary_sensor.ping2_is_available_2') does not have a unique ID, therefore its settings cannot be managed from the UI. See the documentation for more detail.

After upgrading to version 2023.9.1, this problem has disappeared!
Unfortunately, after a while, this false binary_sensor reappeared.
The problem is still relevant.

I completely restarted the computer with HA and this problem is not there. I’ll hope she doesn’t happen again.
I also changed he MQTT version number for Z2M from 4 to 5.
I don’t know what affected more, but now there is no problem.

After restart HA this problem present again :frowning:
Does anyone know how to fix it?

As the ping binary sensor does not support an unique id, it can be difficult to fix.

Maybe this still needs to be corrected?
This “false” binary_sensor disappears every time the computer restarts. After the HA restarted it reappears.

The same problem with statistics sensors. I created these sensors with unique_id and still can’t remove them from Entities.
If you make a new user, then this is not visible to it. This problem is for owner only

I found the answer here:
You need to use the Service purge_entities and it really works.

It reappeared. I no longer understand what it depends on and how to remove it for good.

I think I’m seeing this issue as well