How do I get Tuya working on my Home Assistant?

I put it on my configuration.yaml but it does not work

can you share your code?
It works fine for me. Of course you need to first set your tuya device in the tuya app on a phone

Please see the sticky post for the kinds of things we need to know.

And FYI, not all switches work. I also messed around for a while until I realised that…

1 - All numbers in yaml need to be in inverted commas - so if your username is your mobile number then it needs to be in inverted commas. As well as the country code. Mine kept says wrong user/pass until I did this.

2 - If the component seems to run (ie no errors or notifications) then you may have an unsupported switch. My switches are unsupported so don’t show up in HASS. TOP TIP - Scenes do get found by Hass so I made an ON scene and an OFF scene that shows as a scene in HASS which I can at least use in automations (and turn the lights on/off)


1 Like

In addition and if it’s possible ( you haven’t mentioned what Tuya devices you have) you can look at flashing your device with Tasmota. Here is an example:

This is not true. If a configuration variable in an integration setup specifies number it does not need to be in quotes. If the option asks for a string and you supply a number it needs to be in quotes.

See the green highlights:

The underlined section could do with some clarification though.

I only have 2 lights

It says if they turned off but they don’t show up in the menu

What menu?

Nevermind, I had to put the entities myself

Hey @HomeAnon
Can you please share what you did to add a tuya Device manually?

I this I am having same issue.