How do i kick off auto discovery?

Iḿ really scratch my head with this, following a successful install, it auto discovered a few things, I have since switch on some devices that I want to add, plex, some tv´s etc but I cannot see how to invoke the discovery function and it has not autodetected anything new.

How do i make it ¨discover¨ these new devices?

Thanks
Matt

1 Like

Easiest would be to restart HA.

Discovery happens at boot as long as you have the discovery: key in your YAML (ie, you haven’t commented it out).

I find that with my devices, I prefer to manually set them up in my config. That sometimes gives you a more-consistent experience. But that’ll only work if you have static IPs for your devices.

hmm, restarting home assistant does not produce any results, I tried this several times yesterday.

@ih8gates, are you saying to reboot the computer?

Nope - just restart HA. Could be that Discovery isn’t seeing your device.

thanks but its not working.

Post your config, remember to use the Preformatted text option.

Make sure you have discovery enabled and not commented out in your config.

discovery:

No spaces or anything before discovery or after :

Are the devices you are trying to discover listed as a discovered component?

What devices are you trying to auto discover?

sorry for the long delay in replying, i opted to leave this for now and wait until it matures a bit before trying again. MY xp with it has been that there is far too much manual work required for very little gain.

Iĺl try again in a year or so.

Discovery runs every 5 minutes if Im not mistaken.

/R

is it possible to run discovery service manually? i want to create an automation and run it like 1 time per hour?

1 Like

I don’t think so.

Sonoff T1 3CH

Sorry, but what is this in reference to?

“What devices are you trying to auto discover?”
The device is the Sonoff T1 3CH
https://www.itead.cc/sonoff-t1-us.html

You need to flash with Tasmota and enable discovery…

In other words; in console of the tasmota UI give the command SetOption19 1

I have to say, it’s a bit rubbish that you can’t just say “Go and discover any new devices” - not just for discovery but for any other integrations you set where it will find any of that type at start-up. To reboot the whole thing to do that is, erm, a bit naff. That’s what you had to do in Windows back in the old days. Surely that’s not too much of a hassle to add?

3 Likes

Exactly. I was integrating GitHub - LAB02-Research/HASS.Agent-Integration: HASS.Agent's Home Assistant integration. Adds notifications and mediaplayer capabilities to HASS.Agent - a Windows based client (companion app) for Home Assistant. today and forgot to switch on the other devices prior to restarting HA Core (after installing the integration from HACS).

That resulted in only one auto discovered integration. No way to trigger discovery of the other ones (machines meanwhile powered on). Adding the integration manually does not give the same result as this triggers the legacy mode, not the MQTT based integration. Reloading MQTT integration also did nothing.

So why the hack there’s (still) no homeassistant.run_discovery service?

Restarting HA Core is a pain in general and specifically for this… is almost a joke, at least it’s kinda funny :slightly_smiling_face: