How to set up SlimmeLezer with Home Assistant for dummies

Hmmm not sure. Everything is working over here with the default .yaml modified only with !secret passwords. Did you change anything with the .yaml file for SlimmeLezer? I don’t know if there is a difference between smart meters. Maybe there is something to look into there?

I had the issue i could not connect to the device anymore and could not flash the device via Home Assistant. There after i had to flash it via a laptop (via Home Assistant, but selected Plug into this computer), and therefor i needed drivers. Finally i was able to install the device with these drivers and flash the device successfully: CH341SER.ZIP - 南京沁恒微电子股份有限公司

1 Like

Hi All,

Has someone a good working yaml file for the iskar MT382 dsmr 2.2?

I can’t get it to work :frowning: on my own

Hi Pele, I’m not so familiar with smart meters, but have you tried the firmware specific for DSMR2.2/3.0? There’s something mentioned about it here on Marcel’s website under “Firmware for older meters (DSMR2.x)”: https://www.zuidwijk.com/product/slimmelezer/

That directed me to a fork of the code which might shed some insight. https://github.com/michielappelman/dsmr

thx i wil try that

installed the firmware specific for DSMR2.2.
However waited for hours but no data is coming in :smirk:
Anyone has a clue how to handle,solve it or what to check?

Hey Pele,

Maybe there is something in here that can help: https://github.com/esphome/esphome/pull/2157#issue-712837636

It looks like Michiel Appelman probably knows what to do, perhaps you can get in touch with him on GitHub.

After running fine over 2 months, I looked into the ESPhome dashboard, where I hadn’t been for a while and noticed an update notice for the ‘slimmelezer’. After running this right from there, everything went black. Tried to reflash with the latest and older firmware files OTA, but it stopped everytime after it’s done a few %.

Here’s what happened when updating over the air…

Uploading: [==========                                                  ] 17% 
ERROR Error sending data: [Errno 104] Connection reset by peer

Removed the slimmemeter from the integrations and ESPhome dashboard and worked my way back to the point where ‘slimmemeter’ reports as accesspoint and connected. That worked as the integration was found again. But: no entry in the ESPhome dashboard so no way to reconfigure anything. And my data from the past 2 months was lost.

I cannot seem to restore it. It has an IP, I can reach its own local page directly, but all values except network related values (it has an IP) are empty.

Updating this is not for the faint of heart :frowning:

Got it back on track. Deleted everything, both from the Integrations section as well as from the ESPHome web dashboard. Uploaded latest firmware via USB. Added it to HA via the ‘slimmelezer’ AP.
Went to manually add a new ESPHome entry in the ESPHome web dashboard. Downloaded binary, uploaded that back via USB. Restored my old stats by adding the old sensors to the Energy configuration.

Not touching it anymore for now :slightly_frowning_face:

After yesterdays re-install, I have a fluke in my readings. It has a major negative reading (I have no solar panels nor delivering anything back in any way). I guess it’s not doable, but is there a way to get that reading out of the stats?

HI,
has installed Slimmelezer + on HA and works, in addition to Energy Consumed tariff 1, 2, 3, nan kWh Produced tariff 1,2,3. nan kWh.

How do you update the slimmelezer when its installed in HA with ESPHome?

What is the best way?

My config is as it was after originally installing it:
image

I have been updating my slimmelezer.yaml based on the yaml in the Github repo and look at the latest slimmerlezer.yaml and then manually look at the differences. I did not find another source for the yaml. However on multiple occasions the slimmelezer.yaml in the repo was not working, so can not recommend it.

Personally I kind of abandoned the idea of updating the slimmelezer.yaml and ESPHome myself for slimmelezer and will just flash new firmwares when provided from the slimmelezer website which occasionally get updated.

I wish the slimmelezer could check for updates itself and then I just press a button to install it instead instead of doing the manual check, download, update steps. Maybe it is something that is possible now with the new Update entities in HA.

There is a way to update directly via the ESPHome add-on web interface in Home Assistant, no? I’m not entirely sure what is updated actually, since when I did this just now the YAML version did not change in the configuration…

After selecting to update as shown, you need to choose a connection method (if you have set up slimmelezer normally, “wirelessly” should work). You can see the update progress in the logs. Unfortunately, at least in the HA mobile interface, you need to wait for the update to finish and then click “stop” to dismiss the UI. There is some purple and green text when the update is complete, followed by logging of the incoming P1 telegrams from your smart meter (shown here).

Updating though the ESPHome dashboard updates the ESPHome version/code (if you hover over the Update button it will tell to what ESPHome version it will update). The yaml will not change automatically as that is something you have to provide. The yaml is basically a configuration for ESPHome on how to work with the hardware board connected to the ESP and expose the data to HA.

Most of the time no changes are needed to the yaml, but there have been some changes with the buffer lengths at some point, which I thought were needed for (more?) reliable operation if I recall correctly.

Works perfectly in Luxembourg! Great thanks for the description :slight_smile:

1 Like

hi,

I just got the device. seems to be update to the latest version. It was detected by HA and seems to get all data from the Meter.
the problem I have is that the Energy dashboard is not populated at all. I set a fix price for the daily consumption, but nothing happens.
my original post is here: ESPhome slimmelezer energy config

Hope you can advice.
thank you

I have recently moved to an other house and plugged in the slimme lezer into the new meter. I get nan state output so i guess i have to reset the id or something. How do i do that?