How to start HA, won't restart

Tags: #<Tag:0x00007fc42f03a9d0>

Hi All,
I’m running 2021.1.5, and I can’t get HA to restart. I have a Pi with a few other services going. Is there a way to run a command to start HA without having to power cycle the device? It’s not in a docker.

What OS are you using?

I’m using Raspbian 10, “Buster”

Are you sure? Do you have supervisor in your install?

If you really run Home Assistant Core (in a python virtual environment), create a service for it so that it will be managed by systemd and then you can start/restart/stop it from the cmd line like every other systemd service. Or in the UI go to Configuration -> Server Controls -> Restart

Yes, I followed the manual install procedure. There is no docker in my install. In hindsight, maybe I should have installed it in Docker. But currently, that’s not my problem. How do I fix my current problem?

I told you already, create a systemd service. To be honest if you don’t know what I’m talking about, you definitely should not be running Home Assistant Core (in a virtual environment) and rather choose one of the other install methods..

The manual install procedure actually has specific instructions on a systemd startup script IIRC.

1 Like

Thanks for the link. Based on Burningstone’s advice, I deleted my home assistant folder and then installed docker, and then installed HA in a container. Now, when I check docker to see what is running in containers, I see that HA is running, but I still can’t get the gui to load at the IP address:8123. My pihole service is running on the same machine with no issues. I’m brand new to docker, and it seems to be running correctly, and HA seems to be running in a container in docker. However, it won’t load. This is really strange. Can you point me to some more troubleshooting?

Is there a reason why you aren’t installing the hassos version?

No there isn’t. I don’t understand when to use the different options shown here: Home Assistant Installation Methods

I don’t want to have to reinstall the OS, and I want to keep my pihole server running on the same machine. Those are my 2 constraints.

What command line did you use to run home assistant in docker?

I believe I used the Container option from the link I posted since I didn’t need the OS. It’s been so long that I don’t remember though.