How to use aliases in sentences

Hi all,
I am trying to control the temperature on my various TRVs with a voice command.

I am using the sentence:

Set {heater} to {temperature}

with this action:

service: climate.set_temperature
  temperature: "{{trigger.slots.temperature}}"
  target_temp_high: "{{trigger.slots.temperature}}"
  target_temp_low: "{{trigger.slots.temperature}}"
#  entity_id: climate.living_and_dining_room_heating_group_int0000002
  entity_id: "{{trigger.slots.heater}}"

but it does not work.
When I put one specific climate device as the entity it worked so in principal the sentence does what it should but I guess I am not using the alias correctly.

Any idea?



Have you assigned Aliases for your climate entities so Assist knows what you’re talking about?

Yes I did and it understands the alias as long as I put the specific name of one climate entity into the code (the # section). So for testing the alias itself it works but of course i would have to write several automations, one for each climate entity.

If your having issues have a look at the debug part of the voice assistant to check thats hearing you correctly for the climate entity, and test with text input.

I was having an issue with saying “frontroom leds” being heard as “front room leds” and then it wouldn’t match.


1 Like

Even when I type the command it does not understand that the alias refers to the wall thermostat. The log just shows that the target and everything is empty. So it does not make the connection from the alias to the entity.
hence I wonder whether the syntax in the automation is wrong.

I also tried one of the standard intents:

      - sentences:
          - "(<numeric_value_set>|adjust) <temp> [in <area>] to <temperature>"
          - "(<numeric_value_set>|adjust) <area> <temp> to <temperature>"

and typed

“set temperature in office to 12”

but nothing happened.

Ive not used intents yet.
Ive only done one automation with voice (another shameless plug for my sonos automation)

Also this request might help ?

Huh… I don’t have an option for aliases in any of my voice assistants. Your link only takes me to the main assist page… is it hidden somewhere?

At the top of the page click “Expose”. You will be presented with a list of entities, click the entity you wish to assign an alias to. Click “+ Add Alias” in the pop-up.

1 Like

Got it. So many little hidden gems everywhere!