Hue motion sensors + remotes: custom component


#507

Hello robmarkcole.

I’m trying to use your component but when I load it all my Hue lights are nowhere to be found.

In my Configuration.yaml

I added the hue component and the sensor manually, do you think this is related because i run my instance under docker ?


#508

Hi, doubt its anything to do with Docker, suggest you dig through the previous comments on this thread as this topic has com up over and over.
Cheers


#509

Hi, thank you for this component. Just bought the dimmer. I’m running HA as a docker instance en everything works as expected.


#510

Great work with this! I was just going to buy a bunch of zwave remotes, but now I can reuse my Hue remotes. Saved 250 bucks :slight_smile:

I am trying to control a dimmer (light) with “automations” and got on/off and “if on, dim to max”, working: https://pastebin.com/aNzPQUQL.
But how should I go about to use the “2_hold” and “3_hold” for dimming?


#511

HI,
Any plan the Hue motion sensor will become official components (because I got one and it does the job as expected (besides the warning I get when I restart HA).?
Thanks


#512

For some reason the component just stopped working for me after updating to 0.80.1.

The component is still recognized (I get the usual warning when booting), I also get all the time the “Error updating Hue sensors” message in the log - but this I already got since months without any impact. Maybe now this is a valid message? What does it mean?

Are there any breaking changes in the release? Does any one else have the issue?

I appreciate any help :slight_smile:


#513

Hello, I’ve been using the custom component and it has worked fine for me (running v0.75.2). My question is how to prevent dual actions when pressing a button on the hue switch? On the Hue app, I have to assign a scene to a button press, which will execute when the button is pressed, but also the action assigned in HA will execute. I only want to execute the actions from HA. How can I unlink the buttons from actions in the Hue app itself?


#514

@ccastillo - OS Hue App -> Settings -> Accessory Setup -> “select dimmer” -> Reset (at the bottom of that screen)


#515

My logs are getting flooded with the following since 0.81.x

Error updating Hue sensors
10:02 PM custom_components/sensor/hue.py (ERROR)

Has anything changed or a breaking chance been introduced? Cc @robmarkcole


#516

Mine are as well. like 5 entries a second.


#517

0.81.2 seems to have fixed the issue for me. No more log flood.


#518

I just updated to 0.81.2, but still same error in my logfiles:

Error updating Hue sensors
‎16‎:‎12 custom_components/sensor/hue.py (ERROR)

Is there an update for this component? I want to start using it to automate my lightning, but it’s not working. I do see the sensor and values of the sensor, but automating gives my above mentioned errors


#519

Yeah the update didn’t fix mine either. It’s outputting error every second but it still seems to show accurate sensor data.


#520

Same here, I can see values, but still same errors


#521

Suggest reducing the scan_interval


#522

Im using the default I assume (never defined it). I thought that is 30s? and will changing that value output less errors or it should actually solve the problem?


#523

These sensors need native HA support. I was really surprised when HA didn’t support all of the Hue features especially considering the fact that it’s listed as a Platinum component.

Is someone working on this?


#524

Completely agree
I have a number of automation all depending on the sensors. It really does need official support.


#525

Bit of an HA noob so I’m sure I have missed something obvious, but I cannot find any instructions on how to install the Hue Sensors component. Even the post I originally found (https://www.hackster.io/robin-cole/hijack-a-hue-remote-to-control-anything-with-home-assistant-5239a4) says “I have now created a Component” but doesn’t say how it is installed.


#526

Download hue.py from Rob’s GIT:

That can be found in custom_components / sensor/hue.py

You need to setup a custom components folder in your local config directory:

You’ll have to look that up depending on what platform you’re running, but its the same folder with the config.yaml file.

Place hue.py from Rob’s GIT here:
config_directory / custom_components / sensor/hue.py

Reboot.

As long as you have a Hue bridge setup, your sensors show pop up on the default view page.

Looks like some people are having an issue with 0.81.x, so you might try running an older version of Home Assistant if you get errors.