I2C multiplexer TCA9548A problem with ESPHome 2021.10.1

Just to be sure: a multiplexer like the TCA9548A normally is used when several (identical) sensors have to be connected via I2C to the same controller. Since you only connect one sensor in your example, why are you using the multiplexer?
Did you try to connect the DHT20 sensor directly to the ESP32 (so without the multiplexer), and if so did this work?
And another possible cause of the problem could be wiring. What kind of wiring are you using for the I2C connection, and what length?

1 Like

I need 6 DHT20 sensors they have a fix 0x38 address, I just try it with one single sensor until i get it to run. I tried to connect it directly to the ESP32 and it works.


Here is a picture of the wiring:

I did that you can see in the Yaml Code.

Yep gonna try this now, lets see.

Thanks for helping :slight_smile:


After trying other components, I realized that TCA9548A did not work. With the other ones it works.

1 Like

Right, so that’s clear: you indeed need a multiplexer for that.

OK, so currently it is only a proto setup.
Those short wires should be no problem, if only you assure that the pins in the breadboard are connecting properly. I had some issues with that in the past.
For connecting I2C devices over longer distances I have some good experiences with using UTP cabling, and then feed SDA + VCC through one twisted pair and SCL + GND through another twisted pair.
This is working fine for me for up to 10 meters in length.

Great! Problem solved then :smiley: