iCloud3 v2.1 Device Tracker - iCloud3 v2.2 has been released (10/10/2020)

@martoq The battery level is not returned from the iCloud Web Services for the Find-my-Friends tracking method. The next version (v2.2.0 in the ‘development v2.2.0-rc#’ directory in the iCoud3 GitHub repository here) does pick up the value from the iOS App attribute and passes it along. Or you can just use the battery level sensor from the iOS app for your needs.

v2.2.0 also brings back the Family Share tracking method which does include the battery level. With it, you track the devices that are included Family Sharing list on your 2fa account and you do not have to set up the non-2fa account with the contacts you want to track.

1 Like

Hi there.
I have an issue where I have had to delete and reinstall the HA app on both mine and my partners phone.
This seems to have caused the device tracking to stop.
The simple things like location services are all activated, but I now have multiple device tracker entities
I have bens_iphone and bens_iphone _1 and 2 and 3.

Does anyone know how to get the tracking working again?
There doesn’t appear to be any errors in the icloud3 event log.


Check this out.

@b1nuzz @GaryK That link was nuked when the iOS App went from beta to general availability. The new link is in the Troubleshooting section of the current iOS App docs at https://companion.home-assistant.io/docs/troubleshooting/resetting

iCloud3 v2.2.0 Release Candidate 5 is now available here.

The new features are:

  • When an iCloud authentication fails (iCloud Web Services is offline or there is an error with the username/password), iC3 would reset the tracking method to the iOS App and going back to FmF or FamShr required an iC3 restart. Now, the authentication will be retried in 15-minutes, 30-minutes and 1-hour. When the iCloud Web Services come back online and the authentication is successful, iC3 will go back to the FmF or FamShr tracking method.

  • Fixed a problem with the config_ic3.yaml configuration file processing. The parameters were not being reset to their default values before the new file wad=s processed on an iC3 restart.

  • There may be times when your driving route takes you through the initial station zone. The stationary_zone_offset parameter was added to let you specify a 1km offset multiplier (north or south, east or west) of the Home zone or GPS coordinates of the Initial Stationary Zone.

`stationary_zone_offset` examples: 
1. stationary_zone_offset: '1,0'=Offset 1km North of Home, 
2. stationary_zone_offset: '2,1'=Offset 2km North, 1km East of Home, 
3. stationary_zone_offset: (27.738520, -75.380462)'=Specify the GPS coordinates (parenthesis required)
  • Some minor changes to the Event Log

This is probably the final Release Candidate before iCloud3 is Updated.

Still to do…Finish the documentation update.

Just can’t keep up anymore.:smirk:

I’m trying to get the lovelace card working… need some help.

I’ve copied the card’s js file /config/www/icloud3-event-log-card, and configured a new manual lovelace card with:

type: 'custom:icloud3-event-log-card'
entity: sensor.icloud3_event_log
title: iCloud Event Log

but this returns an error:

Custom element doesn't exist: icloud3-event-log-card.

I saw an earlier post by @pickerin that mentioned also copying icloud3-event-log-card.js.gz but I can’t see this file anywhere in the custom_component folder for icloud3 nor do I see it in the github repo anywhere.

I also tried putting the card’s js file into /config/www/community/lovelace-icloud3-event-log-card (manually created the directory and put the card there), rebooted but still get the same error.

What am I doing incorrectly?

I have mine in: /config/www/custom_cards
with this UI card config:

entity: sensor.icloud3_event_log
icon: 'mdi:information-outline'
title: iCloud Event Log
type: 'custom:icloud3-event-log-card'

I have icloud3 installed as a custom component in the /custom_components/icloud3 directory.

I just moved the card’s js file to /config/www/custom_cards/icloud3_event_card_log.js and rebooted. Used your manual card config verbatim and still get the same error:


Do you only have the js file in that folder? Or do you have any other files there too?

No, I have other, HACS-installed cards in that directory. I did not install icloud3 with HACS.

i didn’t have a /config/www/custom_cards folder already… my HACS-installed cards go into /config/www/community. I’m so confused on how to get this working and why the lovelace card isn’t found.

Did you manually edit the raw lovelace config to add in the type (raw configuration editor)? or just do the manual card specification?

Look in the .storage/lovelace_resources file and see where HA is looking for the card:

                "id": "b1ee78ef98d648b9ac42c5d7a27103d9",
                "type": "module",
                "url": "/local/custom_cards/icloud3-event-log-card.js"

Yes, It’s a manual card with the above configuration.

There’s nothing in .stoage/lovelace_resources that references the icloud3 event log card.

How does HA know to add a reference to the resource? Is this triggered because of the manual card definition?

Well, you can attempt a install with HACS again and see if it writes the resource to the lovelace_resources file. I wouldn’t recommend editing the file directly.

I don’t understand how HACS is involved with writing the lovelace entries since the HACS install is for the integration, not the lovelace card? Or does this happen behind the scenes as part of the icloud3 integration through HACS?

Yes. The card resource has to be defined or you get the red box. So the UI looks for the card’s .js file in lovelace_resources.

now that I think about it, i’m super confused since how would it know where to reference the card in .storage/lovelace_resources since i’m manually copying it after the integration is installed?

The integration, if successful, would have added that pointer for you.

Sorry I’m not following. The js card is in /config/custom_components/icloud3-event-log-card.js after the integration is first installed, which isn’t where it needs to be, hence why you presumably copied it to /config/www/custom_cards/icloud3-event-log-card.js.

If the integration set this up when it was first installed, how would it know to point to /config/www/custom_cards/icloud3-event-log-card.js and not some other directory? (All over this thread is mention of people copying the card file to other folders, e.g. /config/www/, /config/www/community/lovelace-icloud3, etc)

And btw, i know the integration is running succesfully, as i added the device tracker config into configuration.yaml and put my icloud creds. I have 2FA enabled, and when HA starts, I get a 2FA prompt from Apple, so I at least know it’s running and trying to login.