iCloud3 v2.1 Device Tracker - iCloud3 v2.2 has been released (10/10/2020)

Updated to 102.2 and lost all device trackers, mobile and icloud3. Fell back to 102.0.

Config checker results:

[06:54:50] INFO: Installing Home Assistant: 0.102.2...
[06:54:50] INFO: Please be patient, this might take a few minutes...
WARNING: You are using pip version 19.2.2, however version 19.3.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
[06:55:31] INFO: Installed Home Assistant 0.102.2
[06:55:31] INFO: Making a copy of your configuration for checking...
[06:55:31] INFO: Checking your configuration against this version...
[06:59:09] INFO: Configuration check finished - no error found! :)

Same here. It was working for me under 102.1

Extract from log:

2019-11-25 08:56:22 WARNING (MainThread) [homeassistant.loader] You are using a custom integration for icloud3 which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you do experience issues with Home Assistant.
2019-11-25 08:56:22 ERROR (MainThread) [homeassistant.config] Platform error: device_tracker
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/config.py”, line 762, in async_process_component_config
platform = p_integration.get_platform(domain)
File “/usr/src/homeassistant/homeassistant/loader.py”, line 232, in get_platform
f"{self.pkg_path}.{platform_name}"
File “/usr/local/lib/python3.7/importlib/init.py”, line 127, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File “”, line 1006, in _gcd_import
File “”, line 983, in _find_and_load
File “”, line 965, in _find_and_load_unlocked
ModuleNotFoundError: No module named ‘custom_components.icloud3.device_tracker’

That’s a different error than what I received.

I found my problem.

I may have been messed up by hacs. However, I manually replace my icloud3 folder with the 2.01a zip file.

I checked in the icloud3 folder and a few files are missing.

the 2.01 zip file contains:
image

the 2.01a zip file contains:
image

One I put the missing files back except hacs.json, I was able to restart hassio and all appears to be working under 0.102.2

Note, I pulled the missing files directly from the releases page: https://github.com/gcobb321/icloud3/releases

I had updated the icloud3 files prior to updating HA. Still no mobile device_tracker with icloud3 commented out.

I had massive problems yesterday using HACS to update icloud3. It kept creating a ‘device_tracker’ directory and installing ic3 into that, wiped out the ios app integration and wouldn’t let me start from my development icloud3_dev directory (probably because of the device_tracker directory). After restoring HA twice, reinstalling the update, rebuilding the github release files to v2.0.1a, changing some parameters in manifest.json and hacs.json trying to figure out what was going on, my SD drive just couldn’t stand it anymore and crashed. I’m currently rebuilding my Hassio SD drive and reinstalling HA from a backup.

I just double checked the files in the icloud3 repository and reuploaded device_tracker.py and pyicloud-ic3.py. I couldn’t see them but that might have been a Chrome cache issue. . The custom_components/icloud3 directory and the releases zip file look like they have everything.

I haven’t put iCloud3 under HACS yet. I’m doing manual updates of icloud3 and www/custom_cards directories.

UPDATE: Retried the update and was successful this time.

OK, now I’m seeing a little strange behaviour.

I have a second zone being tracked:

track_devices:
- keithdev > fmf_id,second_home

Distance for second_home is identical for distance to home for all four devices tracked under fmf. This configuration was working with 2.0

The logs are something like this:
Results: BaseZone-home > Zone-home, …

and

Results: BaseZone-second_home > Zone-home, …

all details after “Zone-home” are identical.

@Keith.Lovatt Now that I am alive again, I found the problem calculating the interval & distance from the second zone. I have updated iCloud3 and uploaded it to the iCloud3 prerelease directory.

Let me know if it is OK so I can upload it or fix it.

Hi Gary,

Thanks for the quick update. I have just loaded this new version, and I see the expect 138km distance to the second home and 0km to the first.

Looking good!

how do i completely remove this as it has stopped showing in integrations i tried removing the config entries and deleting the directory but when i reinstall its still not in integrations i remember reading something but for the life of me cant find it again

@garywilson4 iCloud3 is a custom_component and not an integration so you will never see it there. Are you referring to the iOS App, which is an integration?

iCloud3 can be installed from the releases area on the iCloud3 repository or by using HACS.

iCloud3 v2.0.2 has been uploaded and is now available. It is a maintenance release and fixes the following issues:

  • Fixed a problem calculating distance and intervals for a second zone.
  • Reformatted some Event Log messages.
  • Fixed the HACS installation problems.

  • Complete documentation with all enhancements and breaking changes can be found here
  • Download iCloud3 v2.0.2 here
  • The iCloud3 Repository is here

I’m not getting any new entities either. in the log the only error i see is iCloud3 Error: Setup aborted for Group-family, [email protected]. No devices to track. any help appreciated

   - platform: icloud3
    username: !secret icloud_username
    password: !secret icloud_password
    group: family
    tracking_method: famshr
    track_devices:
      - gary_s_iphone > gazza.png
      - jacquelines_iphone > jackie.png
      - stacys_iphone > stacy.png

iCloud3 v2.0.3 has been uploaded and is now available. It is a maintenance release and fixes the following issues:

  • Fixed a problem with a malformed message that displayed old location information in the Event Log.
  • Added a list of devices that are tracked and not tracked for the Family Sharing (famshr) tracking method. This is created when the iCloud account is scanned looking for the devices in the track_devices configuration parameter and can help identify why a device is not tracked.

  • Complete documentation with all enhancements and breaking changes can be found here

  • Download iCloud3 v2.0.2 here

  • The iCloud3 Repository is here

  • Complete documentation with all enhancements and breaking changes can be found here

  • Download iCloud3 v2.0.3 here

  • The iCloud3 Repository is here

@garywilson4 Check out v2.0.3 that was just uploaded. It will list the devices not tracked in the Event Log and, if no devices are tracked, in the HA log file and on the Developers Tools>Log screen.

ok so I get this error

iCloud Account devices, gazza_siphone(Not Tracked), stacysiphone(Not Tracked), jacqueline_siphone(Not Tracked)

but they don’t match anything or are these the ones i should use in my configuration?

never mind tried it and got it working thanks

Question, I added icloud3 to my config file, and after a restart my phone tells gives me a code to enter but I never get a notification in HA. Is there a reason for that that anybody knows?

Last night my HA IOS app was updated from v1 to v2.
I see now in my device_trackers that a new device_tracker is generated : device_tracker.iphonetom_2. Previously I had device_tracker.iphonetom

In the icloud event log I see : Tracking devices > iphonetom(iphonetom_2).

Do I need to change anything in the naming of the device_trackers or will this just work?