iFrames over http no longer accessible after HA cloud setup

I recently signed up for the HA cloud trial and so far I’m loving it.

However I have a UI ( on the local network in an iFrame. My local HA instance is on http and this UI is no longer available - see screenshot

Two questions:

  • How can I secure the local instance to run over https
  • As I don’t need access to that UI when away how can I switch to the local HA URL (e.g. 192.168.2.x:8123) when I’m on the local network; i.e. home?

Hi Thomas, as far as I understand: that .8 is not your HA but the webUI of another service.
You cannot use that anymore since when you connect remotely to you HA and you open that iFrame, your device will look for that IP on the network you are connected which will not be able to see the service on your LAN.

I guess a reverse proxy will solve this for you but TBH I have very few experience with that so maybe someone else’s reply might be better then mine.

Thanks Nick and yes .8 is the resource in the iFrame. I’m ok if this is not available outside the LAN but it’s more cosmetic as this error shouldn’t be there outside.

Also when I’m on the LAN I’m obviously still connected to the instance via the HA cloud provided https URL as I get the error even at home.

So the main question probably is, is there a way for the HA app to only use the cloud URL when outside the LAN?

EDIT: Just saw a video re HA cloud setup and it appears we can specify both an external URL and internal URL and following this post (App Configuration menu option missing) I was able to set this up

hello, your problem is normal because you always use your domain name to connect to home assistant, so basically even if you are at home, you go outside, on your pc you go through your IP machine the iFrame works. to have the iFrame from outside your home, you must not use IPs but a domain name for each iFrame.

1 Like