Ikea Styrbar remote in Zigbee Add on?

I bought a new IKEA remote Styrbar. I managed to couple it via the Zigbee Home Automation integration using a Conbee II stick. It only shows the battery status as entity but does not create the controls as it does it for the older Ikea remote IKEA Tradfri Remote Control E1810

Geräteinformationen

Remote Control N2

von IKEA of Sweden

Zigbee Coordinator

Firmware: 0x00010024

Zigbee info

IEEE:

Nwk: 0x0779

Device Type: EndDevice

LQI: 255

RSSI: -25

Zuletzt gesehen: 2021-03-21T10:11:25

Energiequelle: Battery or Unknown

It only shows the battery status as entity but does not create the controls as it does it for the older Ikea remote IKEA Tradfri Remote Control E1810

When pressing the buttons I see something coming up in the events log. What can be done to use this remote?

[0xfa53:1:0x0006] No handler for cluster command 1
[0xfa53:1:0x0006] ZCL deserialize: <ZCLHeader frame_control= manufacturer=None tsn=72 command_id=1>
[0xfa53:1:0x0006] ZCL request 0x0001: []
[0xfa53:1:0x0006] No handler for cluster command 1
[0xfa53:1:0x0006] ZCL deserialize: <ZCLHeader frame_control= manufacturer=None tsn=72 command_id=1>
[0xfa53:1:0x0006] ZCL request 0x0001: []
[0xfa53:1:0x0006] No handler for cluster command 1
[0xfa53:1:0x0006] ZCL deserialize: <ZCLHeader frame_control= manufacturer=None tsn=72 command_id=1>
[0xfa53:1:0x0006] ZCL request 0x0001: []
[0xfa53:1:0x0006] No handler for cluster command 1
[0xfa53:1:0x0006] ZCL deserialize: <ZCLHeader frame_control= manufacturer=None tsn=72 command_id=1>
[0xfa53:1:0x0006] ZCL request 0x0001: []
[0xfa53:1:0x0006] No handler for cluster command 1
Ignoring message (b’057c11490701010d00’) on cluster 5: unknown endpoint or cluster id: ‘No cluster ID 0x0005 on (84:2e:14:ff:fe:90:7c:ed, 1)’
Ignoring message (b’057c11490701010d00’) on cluster 5: unknown endpoint or cluster id: ‘No cluster ID 0x0005 on (84:2e:14:ff:fe:90:7c:ed, 1)’
Ignoring message (b’057c11490701010d00’) on cluster 5: unknown endpoint or cluster id: ‘No cluster ID 0x0005 on (84:2e:14:ff:fe:90:7c:ed, 1)’
Ignoring message (b’057c11490701010d00’) on cluster 5: unknown endpoint or cluster id: ‘No cluster ID 0x0005 on (84:2e:14:ff:fe:90:7c:ed, 1)’
Ignoring message (b’057c11490701010d00’) on cluster 5: unknown endpoint or cluster id: ‘No cluster ID 0x0005 on (84:2e:14:ff:fe:90:7c:ed, 1)’

This seems to be an issue with some of the Ikea gear. You should be able to create an automation using zha_event. It would look something like this.

device_ieee: '84:2e:14:ff:fe:90:7c:ed'
endpoint_id: 1
cluster_id: 5
command: 'on'
args: []

Each button press would be unique and you can create different automations for these.

there is a quirks being implemetend and hopefully be available

ZHA quirks

How did you pair it? I’ve been at it for half an hour and I get nothing. I’m using a RaspBee II on my raspberry 4 and using the Zigbee Home Automation. The only thing I can make the remote do is pair with a bulb - I can’t manage a reset or pairing with the RaspBee.

you need to press the button four times to make it start blinking…
then you can pair it to ZHA, in the meantime there is a provisonal quirk, the two buttons up and down are working, however the buttons left and right are not yet implemented.

this is a custom quirks, so you need to enable custom quirks, define the custom quirks path and need to copy the custom quirk in that path location.

this needs to be in the config.yaml

zha:
enable_quirks: true
custom_quirks_path: /config/zha_custom_quirks

the above is true for the zha with a conbe II stick attached to the raspberry pi4 that is running the Homeassistant OS. I am running 6rc2
i dont know how this works for the Rasbee II as this is an external device, but i assume it should be possible to get pairing of devices initiated and have devices regognized in pairing mode.

2 Likes

Awesome, thank you!

I have been trying the reset 30 times or more, no dice. Apparently the timing on my remote needs to be quite precise - just managed to trigger it now. Will see if I can get it paired properly now.

Thanks for the hints on the integration with quirks :slight_smile:

I have been able to pair it by

  1. set it back to factory defaults (quickly press the pairing button 4 (or 5 times) until the LED flashes
  2. Long press (10s) the pairing button to actively pair the device

Been trying this method for 10 times, but can’t get it to work. Using HA with a Conbee II here. Trying to connect it via Phoscon app Switch → IKEA → Tradfri Remote Control.
What am I doing wrong? Or does it only work in ZHA?

Edit: found out that it only works in Phoscon Beta, not the stable environment.

Hi,

I have a Lidl zigbee hub which has been hacked. I found that after a night of frustration of trying to pair the remote and it trying to take control of some lidl zigbee lamps that the way to get it to work was to do a factory reset - 4 quick presses of the pairing button has to be within 5s then leave the remote next to the co-ordinator after what felt like 30 seconds so prob 10 s the co-ordinator found it and then paired it. it showed a sensor for battery level in the ZHA intergration however that did not come up in Love lace. I then used a blue print from this link ZHA - IKEA Styrbar - Custom Actions and could program all four buttons however very limited functions of on off and more bright less bright no colour functionality. I am not an expert however feel that if the blue print was altered then it wouldbe able to do colour.

So inconclusion I belive that the best way to pair the remote is a factory reset after placing the co-ordinater into scan mode and wait - do not use the 10s hold of the pairing button - I have paired four 1 after the other with this method and no issues.

1 Like