IKEA Vindstyrka deactivated by config entry / deactivated by device - how to enable?

Hey everyone,
I just got myself an Ikea Vindstyrka Sensor and I’ve managed to connect it to deCONZ and its also shown in Phoscon. Homeassistant however tells me that the device is disabled by some config entry and I have absolutely no clue what config entry could be meant by that… I can also read the measured values in deconz perfectly fine. I’ll include some Screenshots down below (Sorry the HomeAssistant one is in German)

Thank you for the help already!


I’ve found a solution to the problem… In case anybody else has this in the future I’ll try my best to explain my troubleshooting:

While trying to connect the Sensor to deconz i had some issues at first. Due to this I’ve tried setting up ZHA and connecting the sensor via the ZHA integration. As this had worked i wanted to see if its shown in deconz too, which it was.
Then I disabled the ZHA integration and by that the entitys and the device were disabled in the core.device_registry and core.entry_registry files. I managed to enable them by following these two comments on other threads:

I connected to Homeassistant via SSH and edited the corresponding lines from deactivated_by: "config" (or device) to deactivated_by: null

I hope this will be useful to somebody else.

Btw: the sensor is working really well and reacting almost instantly

Did you use it off the shelf, or did you do the physical hack that was being touted a couple of years ago as well?

This sensor is a different one. This doesn’t need to be physically modified as it comes with zigbee onboard. I bought it, connected it to power and then to my zigbee network

Right. Now I remember. Last time I looked ( a few months ago) it was out stock in the U.S.

1 Like