Infrared to Wi-Fi gateway from China

If it’s using SmartLife you should be able to add the Tuya integration and use it with your SmartLife account. The only problem is in my experience it shows switches and lights but not necessarily all other devices. But if you add the integration then go into Developer Tools / States you will see it in the list there if the integration is exposing it. FYI Tuya and Smartlife are kind of the same, so the Tuya integration lets you use a SmartLife account too.

There is a “Platform” setting that lets you tell it which one you are using

Could you post a picture if the inside please. So as to see the type if uC used ?

Hello,

Thanks for the reply. Unfortunately I can’t find anything related to that gateway after having added the Tuya integration. That’s very weird. :confused:

Here you are:

Perfect, thanks!
It seems to be an esp8266.
Could you give me a link to where your purchased it.

From what I see; pins and uc the device could be loaded with a custom firmware

there are several on aliexppress:

please update on this, im also interested.
i wonder if it can be used as receiver.

It doesn’t appear to have an IR receiver based on the picture.

Since it is Tuya based, it could quite probably run ESPhome or Tasmota rather easily.

the ir receiver is at the middle of the board :wink:
Bottom left from the ESP

1 Like

I stand corrected… sweet!

That’d be an awesome alternative. I already loaded Tasmota on Tuya smart plugs and it runs very well since then. My mail goal was to get cloud-free. Every smart device I own except Alexa/Google Home (and HASS obviously) can’t discuss WAN for security reasons.

Now, the main question is: how can I reach that? :smiley: I’ve got some knowledge with Arduino, serial ports and so on, thanks to 3D printing mainboards.

In short:

The first step is to determine the pins used on the ESP8266 for IR receiving and IR emitting. By begining from the IR receiver or the IR emitter and following the tracks and components until the ESP.
Once at the ESP compare with the ESP datasheet to determine which pins are connected.

The second step if to see how we can transmit a custom firmware, so as to do this you will need access to the ESP TX, RX and Ground pin, following the picture it seems that there is a direct access available.

The third step is to set the FTDI voltage to 3.3V and connect an FTDI to the GND, RX, and TX (TX ESP with RX FTDI, RX ESP with TX FTDI, GND ESP to GND FTDI)

Connect the FTDI to your USB port and the device to its power while maintaining the reset button of the device (supposing it has) .

From this you should be able to flash a custom firmware.

For your info I have ordered one so as to try it.

1 Like

I got it.
red led = GPIO4
button = GPIO13
ir led = GPIO14
ir receiver = GPIO5

Set GPIO0 (IO0) to GND for programming

1 Like

Great !!! Thanks for the info

Very similar to the Neo Coolcam NAS-IR03W0 IR Bridge on Blakadder template, which I’m waiting for.

GPIO # Component
GPIO00 None
GPIO01 None
GPIO02 None
GPIO03 None
GPIO04 Led1i
GPIO05 IRrecv
GPIO09 None
GPIO10 None
GPIO12 None
GPIO13 Button1
GPIO14 IRsend
GPIO15 None
GPIO16 None
1 Like

so it can be used as a receiver, yes? iv’e been looking for something for the unused buttons on my tv remote. as my neanderthal wife refuses to use the HA app :rofl:.

Hi!

SOOOOO… I finally got time to spend on this. I had tried some weeks ago without success then I figured out that my FTDI was just defect. I got another one and I managed to flash Tasmota-IR on the first try.

It’s now configured to chat MQTT with my HASS instance and…now I don’t really know what to do. I’ve got to make all of this to learn some IR code then be able to execute them. Any clue would be greatly appreciated while I’m doing some research right now. :slight_smile:

Nevermind: I just figured out that blasting some remote to the IR gateway while looking at the Tasmota console would give me all the needed data to create a switch under HASS.

IT’S WORKING, GUYS! :’)

Hey! I tried to flash my device but I’m not able to do so. I’ve same board like one at @vanclec picture.

Is this config valid for flashing?
3.3V, GND + IO0, TXD, RXD. I tried also without 3.3V pin (with usb power).

No traffic on serial port? Could it be locked (the ESP8266 chip)?

I didn’t succeed in uploading to the one pointed in this topic but I had more luck with the AVATTO S06, also called BAKEEY:
https://1technophile.blogspot.com/2020/07/avatto-s06-ir-gateway-compatible-with.html

who has a TYWE3S microcontroller.

It was easy to flash and has the same LED numbers, they are bigger compared to the round IR gateway. It has the same pinout as the one described by @henning1004 and @depen , thanks for it!

You can find all the instructions for the flash on the blog post.