Initial help to access sensors for newbie

I’m trying out Home Assistant for the first time, so a complete newbie, and can’t get my sensors to provide data.The overview page shows the Energy Meter sensor but the entities are in a red circle with “unavailable”, or in the case of the Temperature sensors, a “-” sign.
The more important one at the moment is the Energy Meter.
I’ve added to the configuration.yaml file:

Configure a default setup of Home Assistant (frontend, api, etc)


Text to speech


  • platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

Iammeter Energy Meter entry


  • platform: iammeter
    host: b0:f8:93:2b:b6:d2
    name: Energy Meter

temp/humidity sensor entry


  • platform: mitemp_bt
    mac: a4:C1:38:02:F1:6E
    name: Temp Humidity Sensor 1
    force_update: true
    median: 1
    • temperature
    • humidity
    • battery

And tried both the IP address and the mac address for the iammeter host, but both give the same “unavailable” state, see here for the States snapshot:

Am I doing (or not doing) something really obvious?

Please take the time to read/learn how to properly format code. Check out this post, point 11.

The iammeter platform requires a host, this means ip address or hostname. You provided the mac address. If IP address doesn’t work, then you either have the wrong IP address or home assistant isn’t on your network or home assistant can’t see things on your network.

As for the xiamo mijia BLE sensor, that requires your system to have bluetooth. If you don’t have bluetooth it won’t work.

For both of these issues, you should consult the log and look for errors. The log is located in the config directory as home-assistant.log or in the UI under configuration -> logs.

Thanks for the quick reply. I have also tried the IP address, but this gave the same result. I am on the same local network, and can see data in dedicated android apps using the same ip address in the case of the energy meter.
I am also using a RPi4 as the server, which has bluetooth I read that HA included the required drivers for that device.

Then you should consult the logs and see what errors are appearing.

To echo petro’s point, use the ip address or host name for your IAmMeter integration and please post the logs. There could be any number of things going wrong but the logs should give some insight and narrow the focus. In case you’re unaware (since you said you’re new to HA) the logs can be found by clicking on “Configuration” and then clicking “Logs” at the bottom.

Also I notice in the instructions for Xiaomi Mija BLE it provides different instructions based on the way you installed Home Assistant. Did you follow this guide to set up HA on your RPi or did you set up HA a different way? If you set up HA a different way you may need extra work to get bluetooth working with HA to make that integration work.

Yes, I used the guide you’re indicating to flash the image file firect to the RPi4.
I’ve made progress.
I’ve deleted all references to the Xiaomi sensor in the configuration.yaml file, and now I have values showing for the Energy Meter … one small step!!
Thanks for your help. I’ll try and progress slowly onto the Xiaomi sensors now, but at least have a known starting point with something working, giving me a bit more confidence.