Install help needed with Hassio within Docker QNAP NAS


Need help to install a Hassio version a QNAP NAS within Docker on a QNAP TVS-673 AMD NAS.

First tried to install the normal docker version of HA (without Hassio) using the below command line (after logging in my NAS with SSH). And it runs smoothly:

docker run --name home-assistant --net=host --privileged -itd -v /share/Container/homeassistant/config:/config -e TZ=Europe/Amsterdam --device=/dev/ttyUSB0 homeassistant/home-assistant:latest

Now i’m trying to install a Hassio version. First installing the supervisor within Docker:

docker run --name hassio_supervisor -v /var/run/docker.sock:/var/run/docker.sock -v /var/run/hassio-hc.sock:/var/run/hassio-hc.sock -v /share/Container/hassio_supervisor/data:/data -v /var/log/supervisor-log:/var/log -e SUPERVISOR_SHARE=/share/Container/hassio_supervisor/data -e SUPERVISOR_NAME=hassio_supervisor -e HOMEASSISTANT_REPOSITORY=homeassistant/home-assistant homeassistant/amd64-hassio-supervisor

And now i want to install the Hassio version, but so far no luck.
I have tried the following command, its boots but without Hassio tab:

docker run --name home-assistant --net=host --privileged -itd -v /share/Container/hassio_supervisor/data/homeassistant:/config -e TZ=Europe/Amsterdam --device=/dev/ttyUSB0 homeassistant/home-assistant

Anyone who nows how too?

Do i need to edit some files first?
Or maybe i need another docker version for Hassio?

Tank you very much in advanced.


Unfortunately, it’s not as simple as just pulling in the hassio containers.

true it seems.

but if an script like:
is able to add new containers, why can’t it be done within Docker itself or using an command line string like above?
The alternative is to install and run eg. Ubuntu within Docker, but that is not really a solution I am looking for.

But if you read the script, you can probably duplicate it in a way that works for your system. You can’t just pull in the docker images, there is more setup required than that, as indicated in the script.

Hi, first thx for you replies btw!

I had a look at this post:

Using this ‘docker run’ command with the needed variables, i have managed to setup a docker container for supervisor.

So i thought this should also be able for HASS.IO. But unfortunately im not an export reading the ‘hassio_install’ script and be able to change it to a ‘docker run’ command.

Hi Max. Thx for the pm :wink:

Im not familiar with QNAP in much detail, but if I remember correctly some models have virtualisation support. Would it be possible for you to create an ubuntu VM, install docker and then install on docker in the VM.
My HA setup deployed on my home made NAS that is running VMWare ESXI and its running in exactly this way - ubuntu with docker and hassio deployed.
This way all the hassio addons should work etc.

Assuming you have a supported NAS then ubuntu install does look possible up to Ubuntu 14.10 (Utopic Unicorn)

You are absolutely right… but…
Because QNAP has a own Docker environment by itself i rather not wan’t to install an extra Ubuntu environment. That’s doesn’t seems very smart to me.

Have a look at this post: HASS.IO Docker?

I am hoping to setup/install just the two containers:

  • supervisor
  • hassio
    within Docker.

I only can do this using docker commands (like the Supervisor docker run string) and not the linux commands like Curl etc. These are not excepted by my NAS.

You can give it a go, but I think you will run into problems. that post was written in the v early days of hassio and its changed and improved a lot over time.

A VM is very light weight.
I am using Ubuntu server minimal install and its a few 100 mbs.
When its not doing work its using almost no CPU/memory.

No reason (other than your time) you cant experiment with both though.
but I think you will get a better return on investment with a VM approach

what part is stumping you? It’s not all about the docker run command, some of it is setting up shared storage for the containers, and some of it is configuring env vars.

I have been able to setup a container for superviser including (i think) al the variables i need. But i’m not sure which variables i need for setup the container.

Environment preferable for my QNAP (in my opinion):

  • QNAP OS (Linux based)
    • Docker
      • Supervisor (container)
      • (container)

I have read in forums that it is possible to run and supervisor in a Docker environment. That’s why i think this is the best way to setup, on my Qnap i mean.

Alternative option:

  • QNAP OS (Linux based)
    • Docker
      • Linux (container)

This option give an extra layer. Results in less performance. That is why i’m trying to avoid this.
But again, i might be wrong. not sure what the best

So why not spend some time reading the script? It’s not very long, and once you start reading through it, things will click into place.

You are looking to do something that isn’t documented, because nobody does it. There are other choices people prefer when it comes to HASSIO.
Dedicated Raspberry Pi
Run the script on a Linux machine
Use the VMDK to create a VM

It’s not going to be as simple as a docker run that someone gives you. You will need to figure it out, and if you would read the script, it would make more sense to you.

How did you go @max480?

Im on Day 3. My Journey with my Qnap 679pro has been

  1. QNAP Container --> Docker
  2. Install default QNAP HA (v65)
  3. Reinstall with HA v92

As a HA newbie (but I think the greater portion of people in here will be from the IT industry), 90% of guides are from Hassio or reference hassio eg simple stuff like editing yaml, youd just install the configurator. QNAP youre editing the file from file manager after you install the text editor which is also a different port forward becuase you need the admin console.

I would call the learning slower as you need to figure out the work around from that environment. As you say @flamingm0e if you want it to be simple buy a pi. (or NUC as the guides are now saying :wink:

Now I may troddle off to figure out how to load a hassio container… haha!
Check this reddit out

Also very interested in any progress updates as im considering a QNAP NAS and would prefer not to run in a VM

I managed to get Hassio working using LXC container on my TS-453be following this guide.

I followed the steps on that website twice and nothing happened. The script ends with no errors but no container is created. I tried to manually run the script line by line but couldn’t find any issues.

Any tricks that you used?

I gave up at the end… spending hours without succes… Now running Hassio on a Raspberry Pi with great succes. Easy, stable and more convenient.

Hi, I got it with just one command.

Connect to QNAP via SSH, then run this:

docker run -d --name “hassio-supervisor” --restart always -v /var/run/docker.sock:/var/run/docker.sock -v /var/run/hassio-hc.sock:/var/run/hassio-hc.sock -v “/share/Container/Home Assistant/HASS/data”:/data -v “/share/Container/Home Assistant/HASS/log”:/var/log -e SUPERVISOR_SHARE="/share/Container/Home Assistant/HASS" -e SUPERVISOR_NAME=“hassio-supervisor” -e HOMEASSISTANT_REPOSITORY=homeassistant/qemux86-64-homeassistant homeassistant/amd64-hassio-supervisor

it will install Home Assistant with supervisor and any other addon.
it will create 6 dockers.

you have to change the bold path, with the one that you want to use on your local NAS.

Now, I have to understand how to set autostart to the HA docker.
I’ve to use the API:

curl -u api_container --insecure -sq -XPUT -b cookies.txt https://XXXXX/containerstation/api/v1/container/lxc/homeassistant/autostart/on

Thank you for this! My QNAP NAS has a these folders created:


I then changed the folders to the run command which went OK without errors:

docker run -d --name “hassio-supervisor” --restart always -v /var/run/docker.sock:/var/run/docker.sock -v /var/run/hassio-hc.sock:/var/run/hassio-hc.sock -v “/Multimedia/homeassistant/hass/data”:/data -v “/Multimedia/homeassistant/log”:/var/log -e SUPERVISOR_SHARE="/Multimedia/homeassistant/hass" -e SUPERVISOR_NAME=“hassio-supervisor” -e HOMEASSISTANT_REPOSITORY=homeassistant/qemux86-64-homeassistant homeassistant/amd64-hassio-supervisor

After a few minutes total of 6 containers are added in Container Station, all but one are running. The one that’s not running is hassio_dns -container. After few minutes I tried to connect on my laptop but it won’t show anything. I tried to install the home assistant before trying supervisor version and got it working with the same ip:port. I did however changed the setting on the container under Network for “Network Mode” to “Host” on my previous install which worked. Do I need to change the same setting for “Host” to all these 6 containers or what might be causing why it’s not working? Does it affect that my QNAP is running Celeron, not AMD? I’m semi-noob but trying to learn :).

Thank you for all above advice in this thread. I tried to run same setup as Hypnoosi but got the error: Unable to find image homeassistant/amd64-hassio-supervisor locally

Similar to install commend for the basic HA (as per the first post in this thread) install the error is
Unable to find image homeassistant/home-assistant locally

Any suggestions how to resolve this?