Install Home Assistant, Mosquitto broker and Node-Red on android

All right, fair enough :slight_smile: I’ll give it a whirl tonight.

Out of curiosity I tried to set homeassistant on aarch64 and x86 android and i can’t get that discovery error. So lets try again. :smiley:
Clear data for termux app or uninstall - install to start fresh. Then install only these pkgs.

pkg install python-dev libffi-dev openssl-dev coreutils clang

Create python venv and activate it.

python -m venv homeassistant
source homeassistant/bin/activate

Install homeassistant and run it without pm2.

pip install homeassistant
1 Like

Still not working but… I decided to try on my primary phone (snapdragon GS9 Edge) and discovery works fine… It seems to only be an issue on the GS7 I have. Really odd.

Strange. Some app restrictions on phone? Firewall? Turn off wifi and cellural data transfer and try again.

First of all thanks for an awesome idea that I believe will fix all my problems. I have several old Android phones that I would like to use for device tracking in different areas on my property and I believe this is the answer. I have read pretty much the entire thread but I get lost about half way through there are so many changes would it be possible to upload an updated install method with all the recent recommended packages and procedures Etc… thanks in advance

To install homeassistant in python venv:

pkg update
pkg install python-dev libffi-dev openssl-dev coreutils clang
python -m venv homeassistant
source homeassistant/bin/activate
pip install homeassistant

run it once with hass command and wait few minutes


Open browser and go to


Ok, fixed my problem!

PSA for anyone with discovery issues, you need a recent android version!

The old GS7 I was using had no SIM in it and apparently many US carriers won’t allow updates to phones with no sim. I unlocked the bootloader, flashed an Oreo image and boom, problem solved.

TLDR: Make sure your device has Oreo.

1 Like

Thanks alot !!! I’ll give it a spin

Anyone gotten a Zigbee adapter working from Termux? Is libusb (I’d need to root obviously) sufficient?

I’m not sure you can use usb port for anything other then keyboard, mouse or usb flash drive. See this on github.

Darn, might grab a smart things hub the connect HA with zwave/Zigbee then…

You could use mqtt bridge to connect to smartthings then.

Yeah, that might make the most sense.

Or use raspberry pi. :slight_smile:

Heh :slight_smile: Well ST hub is about the same cost as a pi and adapter… And a snapdragon 820 is much faster than a pi 3

Yes. Hass runs very fast even on older phones. Just that usb port…

Hmm, what about this? might congest wifi pretty badly though.

Need a second host too…

Edit, wonder if this could bridge between Android and termux. No network traffic or external host needed…

Not sure there is a client for usbip on termux.

Darn… Well at least it’s a conceptually possible avenue.

What about something like this? You could plug the adapter into another machine on your network then access it through your network

Whoops just saw the previous post, LOL I would think this would work though not sure I have the experience to make it happen I’m still trying to Simply get to my configuration. Yamyl