Install Home Assistant, Mosquitto broker and Node-Red on android

I just upgraded HA to 0.95 without any problems. I tried to install pynacl as i didn’t have it on my phone and it installed successfully. Did you update termux pkg upgrade? And do you have libffi-dev installed?

How did you manage to install pynacl? Just “pip install pynacl==1.3.0” ?
I have tried on my device but it’s stuck on “Building wheel for pynacl (PEP 517) …”

Other than that, everything is working fine. I was trying to install home assistant using Linux Deploy but on every distro I would always run into some issue… python version too old, venv would make my device reboot, ssh was broken… Then I get to your post and it just works! Thank you so much.

EDIT: Well, I left it running for about 40 minutes and it worked lol, thanks again Vladimir.

1 Like

After upgrading to HA 0.95 can´t start it, it was running fine before. Did pkg upgrade in termux. Logs say: Unable to load auth provider homeassistant: dlopen failed: library “” not found.

  • libffi and libffi-dev are installed
  • running HA in venv

Try to create new venv for homeassistant and reinstall libffi-dev.

1 Like

I forgot I need to recreate the venv after upgrading python, thanks

It’s the same problem How to create venv again?!

If you don’t have any custom things in old homeassistant venv just delete it.
rm -rf homeassistant
Then create new venv

python -m venv homeassistant
source homeassistant/bin/activate

You can try to install pynacl before home assistant.

pip install pynacl==1.3.0
pip install homeassistant

I tryed to install before home assistant and I have read your last post but I have read errori tryed to install libff and libff-dev but nothing change also in new venv

What error you get when installing pynacl?? Is libffi-dev install ok?

Hi Vladosam

I can’t manage to get homeassistant starting up via pm2
Can you give me an hint? I’ve installed homeassistant via venv, and it works manualy.


Show full pm2 start command.

Got it.
I had a typo: /data/data/com/termux/(…)
corrected to : /data/data/com.termux/(…)

Working now. Thanks! :grinning:

When I install pynacl I have this erro : file building wheel for pynacl after android box says me running clean for pynacl and after I have another error that says:
Error could not build wheels for pynacl which use pep517 and cannot be installed directly

Check if you have all this packages installed.

pkg install clang python-dev libffi-dev openssl-dev make

If some of them where missing install them then try to install pynacl again.

Since I could not found any video on youtube, I made a full instruction video here :slight_smile:
Thanks a lot to Vladosam


estoy tratando de instalar home assistant en android y tengo dos problemas de instalacion
package libffi-dev has no installation candidate
package openssl-dev has no installation candidate
¿como lo soluciono?

There are no more dev packages in termux. Just install libffi and openssl.

Got this to work with most of my components except for Android TV due to libusb errors. I installed libusb manually (rooted) but still get not found error.

HACS doesn’t work because it tries to create /TMP which is read only.

You can fix HACS if you change backup_path in

vi ~/.homeassistant/custom_components/hacs/hacsbase/
BACKUP_PATH ="/data/data/com.termux/files/usr/tmp/hacs_backup"

But if you upgrade HACS you have to do this again.
Did you try to locate libusb?

locate libusb

1 Like

The libusb issue is fixed in HA 0.100. In the meantime, you can use this custom component (HACS compatible):

1 Like