Installation Of Home Assistant OS over Ubuntu HELP

Hi folks,
I’m sorry to ask what might be a stupid question to those more learned than I.
I’ve currently been running HA on Ubuntu (on a NUC), which is no longer supported. Haven’t had working updates for a little while now.
I’ve decided to take the plunge and migrate to Home Assistant OS to simplify my life.

When I burn the image using BalenaEtcher per “” my USB device boots, but all I get is a flashing underscore prompt.
I hit the escape key a few times, I can see text flash up for a split second, I can make out text on the screen that indicates that ‘no target was found’, I figure this is due to Ubuntu and it’s partitions being hidden?

I’ve tried a bunch of different utils including:
systemrescue-7.01-amd64.iso (I assume the live version)
to see if I can manually delete the partition table to get it back to a new install experience… No luck on any of these…
I’ve burned the images using both BalenaEtcher and Rufus… Some outcome.

What the heck am I doing wrong?
The stubborn Ubuntu OS (16.0 LTS) keeps booting (with the exception of Home Assistance OS) regardless of what I plug into the usb slots…

Is there a guide someone can point me to work this through?
I can get to the advanced Grub installer CLI (via the Ubuntu Boot Screen), is this something I should consider?

ANY help greatly appreciated.
Keen to get my system migrated to a supported platform.

Okay, so I made a change in my BIOS and I was able to boot into my usb burned with gparted-live-1.1.0-8-i686.iso

I deleted the partitions on my NUC - gone… gulp
I rebooted into Home Assistant OS USB.
Same thing! I managed to get to a HassOS-Boot: / prompt

I enter “boot”.
I get “Botoing entry ‘bootchooser’”
“bootchooser: No valid targets found”
There is furthter text below, along the lines:
id: 1
prioity: 20
default_priority: 1
remaining attempts: 0
default attempts: 3
boot: ‘system0’
disables due to remaining attemps = 0

same as above, different priority (10)…
Booting entrey ‘bootchooser’ failed
Nothing bootable found…

I made the assumption the USB image would automatically install Home Assistant OS?
Is there a default partition type that needs to exist before it’ll work?


So, my original HA install was also running my Unifi Controller… So that means that’s no longer available, so DHCP is dead in the water… :frowning:

Do I cut my losses and install Debian, get a barebones environment up and running then restore?
Or is there a way I can manually configure an IP on Home Assistant OS via the CLI?
:frowning: :frowning:

If I were starting fresh with a NUC, I’d follow this guide.

Thank you so much @tteck
I’ll check it out. It seems to be a comprehensive guide.
I was under the assumption that Home Assistant OS was a single installer which removed any complexity… Have I misunderstood?
I’ve since installed a DHCP server via my PiHole on another pc…
Is Proxmox with virutalised HA a supported configuration?
I’d hate to go through this and end up in the same boat.

Could I ask, if I follow this guide, I can simply do a system restore of my previous full HA backup and hopefully be back online?

Yes it’s supported, you will be using the official Home Assistant OS 5.8 qcow2

If you’re talking about a full snapshot, then yes. You can even upload your snapshot from the onboarding page to make things really simple.

1 Like

Hey @tteck I’ve got Promox up and running, have followed the guide (I think) to the letter.
I’m not able to get my nework interface up and running for my Home-Assistant VM.
I’ve left it for while, no luck.
I’m sure I’ve missed something…
I can’t see any DHCP assigments for my Virtual MAC Address
This is my config:

so close!

Okay, so I don’t know why my config above didn’t work.
I did end up running this

It’s up and running again, I did a full restore.
Unfortunately my IP addresses are different, so I need to make some updates. but much better than having to rebuild from scratch.
Thanks so much!

Did you go under Options --> Boot Order and change it from net0 to scsi0? If not it will not boot

I thought so.
I’ll try again. I guess in this environment there’s no real reason why I can’t continue to build new vm’s!
There’s a slight performance drop in deploying HA this way. But it’s super versatile.

Could I ask another question of you?

In my install I used Deepstack “” to do some processingof my cameras.
I doesn’t seem to be working now.

The insallation procedure requires a docker to be created via the CLI on the baseOS.
I’ll clone my working HA image, and I’ll try and do it from the console of the HA instance?

*** UPDATE ***
I just re-read the guide to deepstack, it requires an 8GB machine to run, I’ve only enabled 4 in my image.
If an integration is installed via HACS it should have come across with the restore right?

hey @tteck, thanks again for the info.
I ended up going back to a basic Debian environment.
ProxMox was excellent, but probably a little much for what I needed. As I only run HA with the addons with Portainer doing what I need it to do so far as docker mgt goes.

Next NUC I get will have more RAM so that I can shift to this in the future.
Thankas again,

I’m actually trying to do the same Ubuntu to Home Assistant OS upgrade you initially tried and the same error. Did you ever get any more leads on getting that working?

I had a bit of a journey to get things going.
Ended up going Debian (abandoned Proxmox, even tough it was awesome).

I had to manually destroy my partitions using gparted-live-1.1.0-8-i686.iso standard installers in proxomox or debian couldn’t repartition.
Ended up using this guide:

Worked fine first pop.

I used proxmox for a while, but couldn’t run all of my integrations as they needed access to all of my RAM, I had to create VM’s under proxmox (had to carve up my RAM). I also needed particular IP / ports for specific integrations and addons to function. Doing a full restore created a headache as I tried to remap integrations and addons to new IP’s…
Proxmox got complex in this regard.
Started again with Debian, full restore, up and running in about 20 miutes from booting via the USB debian installer, including a 10 minute restore.
Followed this:


Thanks. I followed some steps in and eventually got things working with the HomeAssistant OS. Basically what I did was put Ubuntu on a USB stick, booted to it and selected Try Ubuntu, then downloaded balenaEtcher and the image from Ubuntu, wrote it to the main partition and then booted onto that.

Thanks for your input. Had not thought of that but that’s a great option.

I was trying this last night. I booted Ubuntu and did Try Ubuntu, but I couldn’t get Balena-Etcher installed. I tried the downloaded ZIP with extracts and should have run, but never did.
I also tried a few steps to get it installed with apt, but it kept failing to install libraries that it apparently couldn’t.
I’ll try the URL link you posted and have another crack tonight