Installation on a Raspberry Pi4

Just posted a question, but have no idea where i was posted. Hopefully it will be here in teh installation-directory. Here is my question again:


I have a RPi4, with 64-bit Linux. Following the tutorial at Raspberry Pi - Home Assistant

Installing the Home Assistant Core. The procedure works ok until the hass command. It says:

(homeassistant) homeassistant@raspberrypi:/srv/homeassistant $ hass
2022-10-31 20:51:33.279 ERROR (MainThread) [homeassistant.components.http] Failed to create HTTP server at port 8123: [Errno 98] error while attempting to bind on address (’::’, 8123, 0, 0): address already in use
2022-10-31 20:51:33.281 WARNING (Recorder) [homeassistant.components.recorder.util] The system could not validate that the sqlite3 database at //home/homeassistant/.homeassistant/home-assistant_v2.db was shutdown cleanly
2022-10-31 20:51:33.314 WARNING (Recorder) [homeassistant.components.recorder.util] Ended unfinished session (id=2 from 2022-10-31 19:44:46.933512)
2022-10-31 20:51:36.308 WARNING (MainThread) [soco.events_asyncio] Could not bind to [Errno 98] Address already in use
2022-10-31 20:51:36.310 WARNING (MainThread) [soco.events_asyncio] Could not bind to [Errno 98] Address already in use

How can I solve this?


The only wisdom I can offer is that wierd RPi installation issues are down to hardware - e.g. the usual suspects of under-rated PSU, partially corrupt uSD card, or in very rare cases, a bad RPi.

What type of install are you attempting please? A vanilla HASS-OS install “should just work” without any command line work required. If you’re trying a custom virtualisation config, it would be easier to use HASSOS at least until you’ve worked out how it operates at a lower level.

It does take a long time to install and run the first time…

The error message you posted suggests there are multiple components trying to connect to TCP port 8123 - which would be very strange on HASSOS (unless the uSD card image has been corrupted enough to be wierd, but not enough to stop it running).

The reason I tried the core-installation is because I like to do other things with my RPi than just HA. The other day I tried the installation directly on my CD-card, and the HASS-OS started fine. But then I could not reach any Linux OS on the computer, for example to set upp my 1wire configuration, and the mashine are 100% occupied with HA. Thats why I tried to start HA on an running platform, but run into the problems above.
Now - are the Docker installation better in that case? Should I try that out?

My guess it would be easier to install supervised HASSOS, then use HACS to install extras.

It’s sadly a trend that HASS is getting more and more locked down to make it easier for less technical folk to run it - which includes removing the 1-Wire integration from support as some installs used GPIO (mine used the Dallas USB adapter, but migrating to Z-wave sensors was easier to maintain). GPIO integrations are available, but now via .

Thanks. Will gíve the Docker installation a try first, otherwise I go with the supervised HASS-OS as you suggest.