Installation on pi zero w2 stuck at RFCOMM

If you’ve got to that screen it’s looking good. The 20 min message is wildly optimistic - some people posting here have reported hours, even overnight. Be patient. Fortunately you only have to do it once.

Edit: The post you refer to is quite old - got to watch out for that.

Got your point, thank you!

Ok, I’ll see what the status is tomorrow! :slight_smile:

So it’s more than 15 hours without any progress… I guess it just stuck at that point…

The 0w uses a different CPU instruction set then the 0w2. Try HA OS 10.3 for the Raspberry 3 32bit (same CPU as the 0w 2)

Hmm. I put haos_rpi3-10.4img.xz with etcher on the SD card and with this image the screen stays black, nothing happening at all (At least as terminal outoput) but IP is also not reachable… Is this the wrong image or do I use etcher (however) in a unpropper way…

The Link that is provided there is just the 64 bit version (Which I also tried but again screen stays black). I don’t know what I am doing wrong but somehow it seems it was not meant to be…

Ok, I was able to install the lite-32bit-verwsion from Raspi-Imager, so I can logon to SSH now, but for my usecase I would need the HACS-store so a docker environment does not really work, right?

HACS can be installed on all HA installation types : HA OS, HA Supervised, HA Docker and HA Core. It is a custom component, not a Supervisor add-on.

1 Like

Well I’m stuck again! The Raspian Ubuntu comes with Python 3.9 with is not good enough for HASS to run.
So the attempt to compile Python 3.11 on the Zero 2 W resulted in an abort because the device ran out of memory…

Use this image

Runs on Zero 2W, and contains Python 11

1 Like

This is the way (I guess…) I am busy all day gon a try tomorrow. Thank you!!!

Had a short slot and tried the linked image, I get this after coupole of seconds:
Kernel panic:attempted to kill init ! exitcode=0x00000004

*sigh *

Strange. Flashed this image to an SD this morning, since I don’t find my mini-hdmi to hdmi-adapter I set a fixed IP-adress in dietpi.txt, plugged an USB to Ethernet adapter in, plugged the SD card in and started the pi zero w2. Then I went shopping :slight_smile: When I came back I could ping the pi. Logged in via putty.
Installing supervised now.

I tried another SD card, same error. Also tried etcher and Raspi Imager, same error.

I tried the 3rd SD card. Same error. After that I installed a normal 32bit Raspi image via rasperry imager, it just booted the desktop environment.

And also Octoprint does work…

I am out of ideas! :smiley: What am I missing…

Ehm I did something strange /s, I tried the two other images dietpie offers. And after ARMv7 raised the init kill error and ARMv8 did not show anything at all I tried ARMv6 and this seems to work.


tried the ArMv7 from Bookworm mut no hanging at

and on boot screen

sure you have real Zero w2 ?

Shit, I just checked the invoice I bought a Raspberry Pi Zero W :see_no_evil:
I am so sorry!