Installing Home Assistant on a RPi 4b 8GB with SSD boot

Tags: #<Tag:0x00007fc414bd17f0> #<Tag:0x00007fc414bd1728>

Thanks KCYeah! I exchanged the SSD that didn’t have the proper key fitting for the Argon M2 case. I bought this Samsung 250gb. Actually they only had this and the 500gb.
Samsung 860 EVO 250GB SSD 3-bit MLC V-NAND SATA III 6Gb/s M.2 2280 Internal Solid State Drive - Micro Center

And then bought a USB 3 male A to male A. Hooked up the bottom of the argon case and flashed the latest (today) 64 bit RPi4 for the 4gb. Everything was fast. I was up and running within 20 minutes.

Just plugged in my husbzb and it must have an internal memory since it retained all my zwave and zigbee devices. Just had to rename them.

This is so much faster than the Pi 3 I initially was running. That one is going to be setup at my parents place. I think eventually it may get replaced by a Pi 4 or 5 whatever is out then. And of course with an ssd.

Thanks!

1 Like

I have a PI4 with 128Go SD card running HASSOS and just switch to a yKingston 240Go SSD. It works but I do not see any perceptible improvement in speed.
Before the move, I did not have any speed issue except when I restart HA which took quite a moment to perform. After the move, … well … it is the same.
I will keep the SSD since it does not cost much but wonder if it was worth to switch.

This is not normal. Running HA on SSD should be much faster. Did you compare the time to open the history?

No, did not compare History. Because I never look at History and have excluded almost every entities from History.

Well, then there is nothing left to create act load for the SD/SSD. Then it is logical that you don’t see a difference. HA’s history is the one component that creates the majority of disk writes.
The good news is: With SSD you can turn history back on for all of your entities without a noticable performance penalty.

FYI:
I have just upgraded from 5.13 to Home Assistant OS 6.0.rc1 on my SSD based system.
Upgrade is described here.

Looks good so far.

Any reason why you go for the OS 6.0 rc1 instead of the latest OS 5.13 official release?

Because I wrote this guide and want to give feedback to you and to @agners early. ;D

I also hope that v6 might solve some of the problems that other users have described here. (Although the author says in his posting that these issues are still hard to track down and not yet specifically addressed.)

Beside that - no, there is no reason for me to upgrade. My system performs exemplary for over 2 years now on all versions from OS 5 dev till 6 rc.

3 Likes

How did you manage the fan on the X735 board to work?

it just worked, did nothing special. But is always on. keeps my rpi4 on 38°C

So, just tried all this here and only always got a blank screen when booting from ssd.
Normal Raspberry Pi OS booted normal.

The only HassOS that worked was the 64bit Image, so I switched over to that and for now it seems ok

Same here

would like to run 32b as i encounter problem with the raspbee2 connected to the gpio
and esphome seems not to be working
OS 6.0.rc1 32b variant also wont boot in 32b

32b version on my Pi3b with SSD runs flawless but i really want to upgrade to Pi 4 with USB 3.

Can anyone tell how to boot with the 32b
or tell me how to get the raspbee2 working on the 64b os

im in a bit of a loophole

ESPHome works flawlessly under 64bit.

thnx for the quick reply,

My nodes are online and in the log it is running
my flashed Xiaomi BLE sensors are also sending data which is visible in the log
but somehow the data is not pushed through to the entity values. they remain on Unknown

This is not a 64 bit issue. I have many MCUs running under ESPHome on latest production Hass.io 64 without any issues.

Yes I can confirm ESPhome works well on HassOS 64 bit on version 6.0 rc1

I can confirm this process works:

  1. Flashed HASS.io onto Kingston A400 2.5″ SATA SSD with StarTech 2.5″ SATA to USB 3.0 Adapter.
    0b. I had issues with networking, so I added wifi config for first setup. My network is a little complicated. you may not need to do so
  2. Using the RPI Imager, I created a bootloader reset, that read from usb first and sd second.
  3. Shutdown
  4. Removed the SD
  5. Attached the Kingston A400 2.5″ SATA SSD with StarTech 2.5″ SATA to USB 3.0 Adapter
  6. Attached a USB extension cable to my conbee II.
  7. Started up and let the installation happen as usual.
    6b. After setup switched to Ethernet cable.

Home Assistant OS 5.13 on RPI4
StarTech 2.5″ SATA to USB 3.0 Adapter with Kingston A400 2.5″ SATA SSD

NOT working: Adata SSD my previous ssd

Super stable and fast for 2 weeks, no issues rebooting and upgrading the supervisor or installing etc.

1 Like

How much of a speed increase is there for rebooting HA when you go from SD Card to an SSD?

Hi there,

Do we need to place a wpa.conf file on the root of the ssd before first boot, or can the first boot work ok with a direct LAN Ethernet cable connection?

I have ordered all the kit recommended and just waiting for delivery before embarking on this new hardware journey…

First boot will work with a direct LAN cable. After login to HA, you can change to wifi connection if you want under Supervisor tab.

1 Like