Installing Home Assistant Supervised on a Raspberry Pi using Debian 12

Did you make a snapshot before the failed system uppgrade? If yes you should be able to connect the SSD to your PC, browse into /usr/share/hassio/backup and copy your snapshots to your PC for easy recovery after the base install of your rpi4.

The boot folder should be auto-mounted and visible (on a windows machine that is, otherwise /boot)
Just connect the USB drive to a computer and you will see

Or you can run from cli:

sudo ls -la /boot

which brings up (where kernel 5.5.10 is not installed:

drwxr-xr-x  3 root root     4096 Apr  2 12:12 .
drwxr-xr-x 18 root root     4096 Feb 14  2019 ..
-rw-r--r--  1 root root       83 Dec 31 15:19
-rw-r--r--  1 root root   248519 Dec 31 15:19 config-5.9.0-0.bpo.5-arm64
drwxr-xr-x  2 root root    16384 Jan  1  1970 firmware
-rw-r--r--  1 root root 27915840 Apr  2 12:12 initrd.img-5.9.0-0.bpo.5-arm64
-rw-r--r--  1 root root 22656880 Dec 31 15:19 vmlinuz-5.9.0-0.bpo.5-arm64

but unfortunately no boot.cfg

Running as root (su - for all permissions over the system):
locate boot.cfg

delivers an empty result.

Ok sorry so it’s not in the boot folder. Been a couple of weeks when it happened to me and had to apply this fix.

Anyway just connect the USB disk to a computer. On a Windows computer there will be only partition mounted and that is where all the files boot files are (you don’t even get to see the Linux drive what you are seeing now).

boot.cfg obviously only exists on machines running vmware.

Running as superuser

locate boot.cfg

delivers an empty result.

Which means there is no boot.cfg for Debian 10 on arm64 (as I pointed this out before).

Unfortunately no up-to-date snapshot just before the system upgrade.
I’m not so familiar with Linux/Debian, but can’t believe the recommended system upgrade can make my whole home automation unusable and there is no way to recover/rollback without full reinstall. :sob:
There is no way to change the firmware or overwrite the wrong files manually?

This is why backups exist - to protect you against unknown issues, even moreso if you aren’t familiar with what you are doing.

Always make a backup before doing any updates.

1 Like

I’ve been saying a couple of times 'just connect the USB disk to a computer and you will see what I mean". The mount/boot drive is HIDDEN but if you mount it on windows computer you will only see that partition.

I hate repeating myself over and over. I’m not running a VM. I’m using RPI4 with debian installation according to this guide. That’s why I am in this topic and not in the VM topic (if there is any).

edit config.txt (sorry my bad. As I mentioned it was a couple of weeks ago when I did this and i even posted it back then).



1 Like

Thanks you very very much. You saved my day!
After recovering this way, there is something I should do to prevent re-upgrading of this configuration file?

@Koal4 Chill, no need to yell.

It’s a difference to advise somebody to “edit boot.cfg” but in fact you mean “edit conf.txt”, isn’t it? Your tune is quite irritating.

However, @unlikely, you’ll find that file inside /boot/firmware (not hidden at all) or as @Koal4 says if you connect your ssd to your windows machine “you will only see that partition” anyway.

Would you please be so kind to report back to the community whether this workaround works? May help others with the same problem.

Yes, run:

sudo apt-mark hold linux-image-arm64

This prevents updates to update the kernel for the time being.

Actually I said sorry about the mixup (seeing it was weeks ago). But I was trying to help unlikely but you kept ‘de-railing’ my advise and started to fill in the blanks and assume I was using a different kind of setup.

There are 2 txt files and only 1 txt file had the 5.10.x references which was also basically a hint and confirmation what I was suggesting.

When you connect the ssd to a windows machine you’ll se the only fat partition RASPIFIRM auto mounted. Inside that partition you’ll see few text files and a bunch of other files. Just open and edit the mentioned text file.

If only I hadn’t been so intimidated and lazy, I probably would have easily guessed yesterday which file was to be edited.

Just after successful boot don’t forget to apt-mark hold otherwise next reboot fails again.

Thanks again

1 Like

I have followed this guide several times with a lot of help from many in pm and I am still having issues. The issues are consistent. Sometime after the snapshot restore I lose access rights. Usually home assistant doesn’t start on a reboot. I can start it usually with portainer, but not always. When I install samba sometimes I can’t restart it after the install. Once I get home assistant running, after a few hours the pi4 loses network connection. It is still running but I can’t connect to it through ssh. I do not see any of these issues using the rpios (not supported) and HA supervisor or with HAOS 5.4 and below.

The SSD drive is Samsung (have tried others) and either a StarTech 3.0 or 3.1 controller. The power supply is the official 5v, 3A, but have also tried the 5v 3.5 A. The firmware is the March stable version.
I started trying the supervisor and Debian due I and many others having issues with the pi freezing or losing network connections after updating to 5.4+ (I have tried 5.5 -6.x).
Any ideas on what to try next?

try my script

What does your script do differently that would fix my issue?

Did you fix your network issues? This looks very similar to my issues. I am on a wired connection and I lose it after several hours.

I have the same issue with my wired connection. How do I fix this?

It’s the same install, he’s just combined a few steps into one script and wanting to promote it.

You may need to set USB quirks for the external drive to boot and run correctly, assuming it is a supported enclosure/drive. From what I can remember, settings quirks can help. Have a read of this page, specifically the section on Fixing (some) USB Adapter Problems Using Quirks

I’d be interested to hear if that helps to resolve the problem.