Installing Home Assistant Supervised on a Raspberry Pi with Debian 11

Yep, no issues.

2 Likes

what image version have you used? can share the direct link ?

It’s already linked in the instructions.

1 Like

I have just install a fresh Home Assistant Supervised on a RPI3 and restored a snapshot. Everything seems to be working fine so far as I am physical checking what isn’t working.

The DHT integration isn’t working. There is no error in log. The site says to install libgpiod2 which I did. I restart HA, but the temp reading is still unknown. Wondering if I need to reboot the RPI and not HA?

sudo apt install libgpiod2

sensor:

  - platform: dht
    sensor: DHT22
    pin: D4
    name: mdf
    scan_interval: 60
    monitored_conditions:
     - temperature
     - humidity

just a curiousity, maybe a offtopic.

How you can enable I2C on this Arm64 rapi image? or how you get raspiconfig :wink:

I am having trouble getting this to work with a Pi3b+ and suspect its my lack of knowledge and needing to change something in the process.

following the guide in post 1 I cant get past updating the system. boot from SSD hangs after reboot at 1.5 same as in post 14 with message “sd 0:0:0:0 [sda] Attached SCSI disk” and progresses no further.

my adapter is startech 3.1 from the list of working with Pi4 as it was bought with the intention of moving to a Pi4 later.

I have tried a number of the suggestions in the thread and a few off the wall ones too. if I use the bullseye image on the same page I can upgrade and reboot no problem but obviously it wont go much further as its the wrong image for this guide.

if I don’t update the system I can get all the way through to a working HA but again as soon as I update the system it fails to boot.

I don’t think its USB power but to be sure I have a powered hub on the way to remove that as a possibility however I am guessing in my ignorance that it may have something to do with the command-

apt-mark hold linux-image-arm64

I am running this and getting confirmation that the hold is active but perhaps this needs to be different for the Pi3?

my config.txt is

# Switch the CPU from ARMv7 into ARMv8 (aarch64) mode
arm_control=0x200

enable_uart=1
upstream_kernel=1

kernel=vmlinuz-4.19.0-14-arm64
# For details on the initramfs directive, see
# https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=10532
initramfs initrd.img-4.19.0-14-arm64

as this is 4.19 rather than the 5.9 in the posts above i suspect this is also a Pi3 vs Pi4 difference

as a dumb noob I have been more focused on the HA side than the Linux so I hope I am missing something obvious to you experts

thanks for any help

Exactly which image did you install onto the RPI3+ which makes the system unbootable after updating the OS?

For the RPI3+ it has to be the second image from this page (2021.02.10 10 (Buster) 3 3B+):

Bullseye is is Debian 11. As the title of the instructions already is pointing it out these instructions are for Debian 10 (Buster) only. kanga_who’s scripts which are doing the magic in the background are fitted to Buster but not to Bullseye.

To find out which linux image should be put on hold just type the following at the CLI:
$ sudo dpkg --list | grep linux-image

The second in the list (hi) should be the one to put on hold.

Hi Tamsy,

I was following the guide exactly using the buster image on the linked page. I tried the bullseye image just to see if it would work with the updates and retain the usb boot which it did but not for anything else.

The raspi has been really buggy and i simply wanted to get away from sd cards.

My pi3 was unstable on 64 bit anyway so perhaps its a hardware issue. I was considering upgrading to a pi4 or odroid but am going down a different route now with homeassistant running on a VM in an Esxi server which so far is being far less hassle.

I think its time for my Pi to be given simpler duties

Thanks for your help

1 Like

Does anyone know how to correct the situation I have stupidly dropped myself in please?
I stopped and deleted the homeassistant container (using instructions from a previous version for intalling HA). Before this, I had set up HA Supervised using Kanga-Who’s instructions and it was running fine on my RPi4 with Raspberry Pi OS.
I have tried repeating the instructions given by Kanga-Who in the above installation guide. The CLI ends with the usual “First setup will take some time…”. But I have waited 15 mins and my HA page won’t load, and looking at Portainer, the homeassistant container has not been recreated.
I still have all the other HA related containers running, and I have the “homeassistant/raspberrypi4-64-homeassistant:2021.5.5” image still loaded.
Is there a way I can get this all running again please?
If not, please could someone tell me if the tar backup file I took an hour ago can resurrect my HA, and if so, how do I restore if from the command line?
Thanks very much in advance.

If no one gives you a better answer you can always start over as long as you have a current snapshot. Follow the tutorial and restore the snapshot through onboarding. Should be done in 30 to 45 minutes max.

assuming you have a recent backup (and that might be a big assumption), you will get operational far faster by just doing a complete reinstall than struggling fixing this type of issue.

Thank you for your pieces of advice. Having messed about trying different options I decided to reboot the RPi. And as if by magic the ha container was reinstalled. There must be something running in the background that re-creates the container if it is missing.
Thanks again.

I’m trying to get this running for quite a while now, but so far no luck.
the install script says its finished and that i have to wait for myip:8123 to come online. but this never happens.
sudo journalctl -f tells me that for some reason hassio-supervisor is trying to download aarch64-hassio-observer with tag 2020.10.1 but it looks like that version doesnt exist

somebody any idea?

Without telling which OS is exactly used as the base system its hard to say.

There is an issue with the Observer being tagged as Dev that looks to have been fixed.

Hi,
I made your choice too and passed from SD card to USB SSD on a 3b+ model. My external disk is quite general, low profile I would say (china ssd and generic external envelope (from ssd to USB)) and what I found while configuring all was that the cable I was using were not very good and using another worked, so pay attention to that. After changing the cable, the ssd works without an external power and that is what I wanted.
Hope it helps,
M.

Is it solved now?

Can unhold?

Thanks

No it isn’t and I think it wont ever be for Debian 10 Buster on the Raspi4.

Just stay with kernel 5.9.15-1~bpo10+1 (2020-12-31) aarch64 until HA Supervised on RPI4 supports Debian 11 or later. You wont be missing anything anyway.

Tested images has been updated and the image provided seems to have the problem of boot even if you don’t make any update. Someone has a link to previous version ?

After you do an update via SSH i.e

sudo apt update && sudo apt upgrade -y && sudo apt autoremove –y 

what should be done next? I do from the same SSH window a Sudo reboot. Is this correct?