Installing Home Assistant Supervised on Debian 11

Technically, installing anything else than the required dependencies for a Supervised installation does make it unsupported, so the opening comment is accurate.

1 Like

and honestly who knows what bastardry is coming given the issue with ANY container made it unsupported only a couple of weeks ago after years with no issues…

5 Likes

I have trouble to get my bluetooth usb stick to find my BLE sensors. I use ble to get the data (this has worked before on my raspi3B+ very well.

How does HA supervisor can access the USB device? If I go to supervisor → host > hardware the stick is shown as Bluetooth_Radio. Did this also mean HA can access it?

Thanks

Hello,
A year ago, I installed ha supervised on my openmediavault 5.5 using the old script

curl -sL https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh | bash -s 

which allowed me to choose the data folder on a disk accessible by the samba of omv.
I unfortunately broke my installation. And the old script doesn’t seem to work on omv 6 anymore.

So I would like to use the official way

dpkg -i homeassistant-supervised.deb

but I don’t see how I can declare the folder for
-d | --data-share $ PREFIX / share / hassio data folder for hass.io installation

Or is there a way to move this folder after installation?

Shamelessly copy/pasted without giving credits from here.

1 Like

Yes, you wrote it out nIce, and I copied it back. Credit need to be given.

We all stand on each other shoulders.

Hello, I created a Debian11 VM on my proxmox server and now I get the following error message:

sudo bash -c "$(wget -qLO - https://raw.githubusercontent.com/Kanga-Who/home-assistant/master/hassos_install.sh)"
bash: Zeile 62: pvesm: Kommando nicht gefunden.
numfmt: ungültige Zahl: „failure“

That script is a different script. Use this to install supervised on debian 11:

wget https://github.com/home-assistant/supervised-installer/releases/latest/download/homeassistant-supervised.deb

dpkg -i homeassistant-supervised.deb

Ahhh, yes it does.

You are trying to run the HA OS script on Debian - it won’t work.

Either follow the Debain 11 install guide, or, the Proxmox + HA OS guide.

I agree, that’s why I‘m running HA supervised as a VM on Proxmox. I use supervised only to run ser2net (although still in planning phase).

I’m in the planning phase right now. Switching from IoBroker. What is the exact difference.
What is different with HA supervised?

Where can I find the correct installation instructions?

You need to do some reading my friend. Start on the HA website.

This guide is to install HA Supervised using Debian 11 as the OS.

If you want to run a VM, using Proxmox, follow this guide.

1 Like

oh yes i read it before and test it
Error on this point

Now i testet Proxmox Helper Scripts

bash -c "$(wget -qLO - https://raw.githubusercontent.com/tteck/Proxmox/main/pve6_ha_container.sh)"

and now lxc is locked

pct unlock 107 

don´t unlock :man_shrugging:t2:

You ran a pve6 script, you’re on pve7

This has nothing to do with the OP topic

1 Like

pve server reboot…its ok… what is login password

:see_no_evil:sorry its not my day

1 Like

This is a strange decision. Docker isolates containers, that’s the whole point. Why on earth would installing another container would invalidate an install?

That and blacklisting Ubuntu… Debian hardware support is quite lacking and won’t enable the display adapter on my small server where I was running supervised HA on Ubuntu until some dev decided they hated Ubuntu. I can’t install Debian on that server. I’m now running the VM but I get random problems with home assistant dockers crashing and stopping for no reason. It’s very unstable compared to my previous Ubuntu setup.

Sad to see a successful open source project like this take the wrong track.

Maybe it’s time to fork the project.

3 Likes

Hello everyone.
I was using HA supervised version for quite some time on RPI4 4GB. until recently i got my RPI SD -Card crash. Since then i am trying all available things to reinstall HA supervised on both Debian 10 and 11 but unfortunately was unsuccessful. recent, the following installation guide i followed on for Debian 11

Everything went well as per the guide. but after the installation was unable to connect to the HA frontend. After diagnosing, i found the HA core is keep crashing in HA supervised.

21-12-04 23:57:24 INFO (MainThread) [supervisor.resolution.evaluate] System evaluation complete
21-12-04 23:57:24 INFO (MainThread) [supervisor.resolution.fixup] Starting system autofix at state CoreState.RUNNING
21-12-04 23:57:24 INFO (MainThread) [supervisor.resolution.fixup] System autofix complete
21-12-04 23:57:24 INFO (MainThread) [supervisor.host.services] Updating service information
21-12-04 23:57:24 INFO (MainThread) [supervisor.host.network] Updating local network information
21-12-04 23:57:25 INFO (MainThread) [supervisor.host.sound] Updating PulseAudio information
21-12-04 23:57:25 INFO (MainThread) [supervisor.host.manager] Host information reload completed
21-12-05 00:01:14 INFO (MainThread) [supervisor.homeassistant.module] Update pulse/client.config: /data/tmp/homeassistant_pulse
21-12-05 00:01:15 INFO (SyncWorker_3) [supervisor.docker.homeassistant] Starting Home Assistant ghcr.io/home-assistant/raspberrypi4-64-homeassistant with version 2021.11.3
21-12-05 00:01:15 INFO (MainThread) [supervisor.homeassistant.core] Wait until Home Assistant is ready
**21-12-05 00:01:20 ERROR (MainThread) [supervisor.homeassistant.core] Home Assistant has crashed!**

I also tried to roll back to the previous core versions and later to the dev channel. But nothing worked out. I would really appreciate if someone can help me to understand where exactly is the problem and how i can get it fixed.

Many thanks in advance
Simer