Installing Home Assistant Supervised on Raspberry Pi OS

Thanks for taking the time to reply to my questions. All makes sense. I wish I could get Debian set up in 20mins! Last time I tried, I struggled to get wifi working. I’m going to have to get familiar with setting it up with a bit of trial and error and just use ethernet for the initial setup I think. One of the main and significant benefits of having an SD card inserted in the Pi4 with a working bootable “image” of the attached USB SSD the system boots from is that if there are any issues with the USB drive or an update goes bad I can just remove the USB, boot from the SD card and then clone back to the USB SSD. I’m setting up a HA system for non-tech savvy people so having a failsafe like that is very valuable. Off topic though!

Debian 10 64bit. I have searched for an answer but can you or someone else point out what might be obvious in how to get the 64bit version of Debian installed on the Pi4? Is it just a case of using a 64 bit kernel like with Raspberry Pi OS?

EDIT: I’ve realised that following the instructions as-is installs 64bit and I’ve got a fully working, stable and supported installation! Thanks @kanga_who!

Is anyone here successfully output the audio through HDMI? I have successfully installed the supervised HA in my Raspbian and it is working fine.

I’m planning to use it as media player and it is connected to HDMI display that has speaker. I have install the Spotify addon but can’t play thr music through the HDMI speaker. Under the add-on, I see there are default and dummy output for the audio but none of it seems to work.

Also, when I tried to check the HA audio info with terminal, it shows nothing under output section.

I can play youtube music through the Raspbian browser, so I don’t think the problem from the Raspbian.

Please advise.

I think this may solve your problem:

Thanks for the reply. However, this addon doesn’t seem to fix my problem.

When I run ha audio info in the terminal, the card and the name are showing null. I think this is the problem.


On my another RPi instance where it’s running HA OS, the card is showing 0 and name is showing…

Does anyone how to configure the audio output in Supervised HA in Raspbian?