Installing Home Assistant Supervised on Ubuntu 18.04.4

Tags: #<Tag:0x00007f73b48d5bb0>

Sounds like yiur templares might be faulty. See the 0.115 release thread. If I am right then moving to debian won’t help.

chief, you were absolutely right! it’s all about templates! thanks for heads up!!!

I have quite a few docker containers already and my host has multiple IP addresses. How can I set which IP address HA will get?

HA presents to the world as the IP address of the host.

The 172. addresses are internal to docker.

I don’t get why HA in docker on Ubuntu is “unsupported” though. Who’s gonna install only HA on something like a NUC with option to access the whole Ubuntu/server. Maybe I’m missing something.
Everybody starts on a Raspberry PI, but after a while (and more devices and integrations) the need if there to move so something more powerful. Unless Pi 4 is powerful enough, and SD cards have magically improved (or are people using SSD?).
It is also awesome that they made HassOS, don’t get me wrong. But it feels a bit constrained.

VMs are a thing too. For example I have a powerful server, but it’s running ESXi, so I can use HomeAssistant with the entire HAOS as a VM, and still have other VMs for a windows server, ubuntu, etc.

I hadn’t considered VMs to be honest. Not that I’m a Docker specialist, but I know more about it than Hypervisors.

So ESXi (or another hypervisor) on a host machine, and then run Home Assistant (full w/ supervisor) as a VM and you’ve hot yourself a support installation? Cool.

I see a lot of ESXi post when Googling. Might be personal, but is it overall the best Hypervisor (features vs ease of use)?

Might there be issues while running in a VM regarding access to USB (ie. zwave or zigbee) or network things?

Yup, it gives you a fully supported system running their OS.
As long as you don’t muck with the network settings or anything, it’s all good, and you can do USB pass-through etc as needed.

Definitely a personal opinion imho. Lots of people here use Proxmox to have a HA VM, for example.
Personally, I use ESXi at work a lot, so I’m just more familiar with it and didnt want to learn how to use another hypervisor for this purpose.

In ESXi (and proxmox, as I understand, and im sure other hypervisors) you can simply choose to pass the device through from the host to the VM and it works just fine. In the screenshot below, I have my Z-Wave stick and Zigbee stick passed through.

1 Like

So now we have a host, a hypervisor, to install HassIO, which installs another virtualization layer (docker)… seems silly. In any case, I’m going the VM route myself. Let’s hope HA Docker becomes a more “supported” option down the road.

HA Container (what you called “HA Docker”) is a fully supported installation method of HA.

As long as it’s installed on a Debian OS and you don’t put anything else on that machine except for HA and the apps (add-ons) maintained by the Supervisor.

1 Like

IMPORTANT: Home Assistant grabs Linux audio as part of it’s startup routine. If you want to use audio output in your Linux desktop, you can find the solution:

1 Like

@kanga_who Thanks for you guide!!! worked like a charm on Ubuntu 20.04 Server. However I have issue restarting HA or even Stopping it. The only way is to re-start the docker or host. This is the error:

20-10-04 01:37:11 ERROR (MainThread) [supervisor.utils] Can’t execute restart while a task is in progress
20-10-04 01:37:11 ERROR (MainThread) [supervisor.utils.log_format] Type of message is not string - expected string or bytes-like object

Any help is appreciated.

My total respect for being so detailed in the tutorial. Everything you indicated worked correctly and no problem with Ubuntu 18.04.5 Server.
I have installed it on an old notebook that I did not use.

I just wanted to say thank you. Greetings from Uruguay

2 Likes

My 18.04.4 install updated to 18.04.5 sometime in the past week and now won’t upgrade from 0.115.6 to 0.116 or supervisor 245 to 246/247.

20-10-08 03:32:30 INFO (SyncWorker_7) [supervisor.docker.interface] Pull image homeassistant/amd64-hassio-supervisor tag 247.
20-10-08 03:32:30 ERROR (SyncWorker_7) [supervisor.docker.interface] Can't install homeassistant/amd64-hassio-supervisor:247 -> 500 Server Error: Internal Server Error ("Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io on [::1]:53: read udp [::1]:41790->[::1]:53: read: connection refused").

It’s strange, I can access my instance remotely (through Nabu Casa) and HACS modules update.

Update: Turns out to be something to do with the AdGuard add-on. All fixed

Getting Error when run supervised-installer.sh: invalid reference format

Hello,
I am running Ubuntu 18.04.5 on mac mini 2012 dual boot.

logs:

~# curl -sL "https://raw.githubusercontent.com/Kanga-Who/home-assistant/master/supervised-installer.sh" | bash -s
[info] 
[info] This script is taken from the official
[info] 
[info] Home Assistant Supervised script available at
[info] 
[info] https://github.com/home-assistant/supervised-installer
[info] 
[info] Creating NetworkManager configuration
[info] Restarting NetworkManager
[info] Install supervisor Docker container
invalid reference format

I am stuck, what can I do to fix it?
10x.

The issue was empty variable for HASSIO_VERSION
When I set it manually it works for .

docker pull "$HASSIO_DOCKER:$HASSIO_VERSION" > /dev/null
docker tag "$HASSIO_DOCKER:$HASSIO_VERSION" "$HASSIO_DOCKER:latest" > /dev/null

After I fixed it I got another issue:

+ docker pull homeassistant/amd64-hassio-supervisor:247
Error response from daemon: Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io on [::1]:53: read udp [::1]:46143->[::1]:53: read: connection refused

I fixed it with adding sleep to the script before docker pull, its seem that it take time for network to return after “Restarting NetworkManager”

Hi guys,
Help please, I’m new to Linux.
Installed according to the Hassio instructions on
Ubuntu Server 20.04.1 LTS. Installed snapshot from my Pi3b +
Everything works until the reboot. After booting, HA does not start. I suppose it’s about autoloading. How to fix it?

Hi when i install docker i get this: How can i continue to install process ? Thanks

curl -fsSL get.docker.com | sh

Executing docker install script, commit: 26ff363bcf3b3f5a00498ac43694bf1c7d9ce16c

  • sh -c apt-get update -qq >/dev/null
  • sh -c DEBIAN_FRONTEND=noninteractive apt-get install -y -qq apt-transport-https ca-certificates curl >/dev/null
  • sh -c curl -fsSL “” | apt-key add -qq - >/dev/null
    Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
  • sh -c echo “deb [arch=amd64] https://download.docker.com/linux/ubuntu groovy stable” > /etc/apt/sources.list.d/docker.list
  • sh -c apt-get update -qq >/dev/null
  • [ -n ]
  • sh -c apt-get install -y -qq --no-install-recommends docker-ce >/dev/null
    E: Package ‘docker-ce’ has no installation candidate

Are you running the command as root?

sudo -i
curl -fsSL get.docker.com | sh

i was using ubuntu 20.x

i just install ubuntu 18.04 now everything works ok.

Thanks

1 Like