Installing Home Assistant Supervised on Ubuntu 18.04.4

Tags: #<Tag:0x00007f7393566bf8>

Would there be any value to explain the security risk involved in running an unexamined shell script? For example, Pi-hole’s installation instructions mention it and offer alternatives:
Pi-hole: One step automated install

FWIW, when the installation script was still available from the official repo, I reviewed it prior to executing it. It only took a few minutes and gave me insight into what it was doing to my server.

I don’t disagree. I’ll add that as an edit tomorrow when I don’t have the contents of a bottle of red wine in me :wink:

2 Likes

Thanks and cheers! :wine_glass:

1 Like

Great guide, but please change the title to include (on intel/amd). I received my brand new Rbpi 4 8 Gb this afternoon, but the guide does not really work. Anyway, I’m running already ubuntu and HA from a HDD.

Good idea, I will do that. I have an updated Pi install guide using Raspberry Pi OS (Raspbian) coming tomorrow.

3 Likes

@kanga_who thank you for your continued work on community based documentation. It’s folks like you that allowed me to try and succeed at migrating to HA. I always knew that Home Assistant was where I would end up because of the its HUGE footprint, but just never had the time to wrap my head around all the moving parts. It can be very intimidating when you don’t understand the various terms and even more confusing when trying to pick an install method.
It was walk-throughs like the ones that you are creating that allowed me to get my feet wet without the fear of drowning.
I just wanted to say that I really appreciate you taking the time to put these together. I’ve had to make documentation in the past and it’s a painfully tedious task and can be really exhausting because you have to constantly try to think like someone you are not.
Bravo sir :clap:

2 Likes

Thanks mate. I’m glad you find it helpful. :+1:

Thanks for the reply! Before doing that, I actually just the “restore” button from the GUI under supervisor --> snapshots…and it worked! Even Zigbee2MQTT is up an running as a docker container, didn’t even have to reconfigure the adress of the CC2531. So maybe add that to the guide, super easy to restore. Just did a snapshot with the Google Drive add-on (https://github.com/sabeechen/hassio-google-drive-backup), turned off the Raspi, ran the script to install it on my linux machine and did a restore!

The only thing that did not work was HACS, obviously. i wanted to reinstall it but I am not able to locate the folder you mentioed. I am not able to see anything under my usr - no share, no hassio, nothing. Where are the config files located?

Thanks in advance!

EDIT: nevermind, I am just a linux noob. Found the folder.

1 Like

TIA.

Just as I get Raspbian working on my new SSD - your timing could hardly be better. Waiting with bated breath.

@kanga_who I tried installing HACS and it did not work, ran into some troubles and wanted to start over. Tried to kill or stop the containers, but they also boot back up? I am not able to kill and remove them to start fresh. Can you please add a section on how to remove everything properly? I guess the script is brining them back everytime I kill the container? Thank you very much in advance.

1 Like

Great stuff! Thanks for sharing.

Wondering if anyone has managed to install HA Supervised on a Docker container running Ubuntu 18.04. I’ve been unable to.

Why would one install docker inside docker? HA Supervised is already setting up docker containers for HA Core and the Supervisor in your host. :thinking:

Development.

I wonder if it would now be more accurate to say it runs “Home Assistant Container”?

It’s technically correct to say it runs Home Assistant Core but when distributed as a docker container it is now known as Home Assistant Container.

Home Assistant is a full UI managed home automation ecosystem that runs Hass.io Home Assistant Home Assistant Core Home Assistant Container, the Home Assistant Supervisor and add-ons? :upside_down_face:

Edit: Yes, you’re probably right. I’m just being facetious

Yeah, I know. The product’s name is going to need its own GitHub repo to keep track of all its changes!

The only reason I’m suggesting to refer to Container is to emphasize that the Supervised version is all docker-based. Home Assistant Container is Home Assistant Core but distributed as a docker container (i.e. the python code that makes Core plus a docker operating environment).

1 Like

Okay, so are we saying this guide is not good for installing Supervised on Ubuntu on the Pi4? I just read the whole thread to get it set in my head for this evening and then saw the post about it being for Intel/Amd only (oops) haha.

On a Pi4, you download the desired image from here :

And flash it to your sd-card using belana etcher.

under 2.2, you replace with

sudo -i

apt-get install -y software-properties-common apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq network-manager socat

systemctl disable ModemManager

systemctl stop ModemManager

curl -fsSL get.docker.com | sh

curl -sL "https://raw.githubusercontent.com/Kanga-Who/home-assistant/master/supervised-installer.sh" | bash -s -- -m raspberrypi4


or – -m raspberrypi4-64 if you installed 64-bit

Here’s the Pi guide.

Hey @kanga_who thank your for your continued support of Home Assistant - It is really cool.
I’m pretty new to the home automation scene, while I have about 30 MQTT devices I had been doing it via Hoobs.

While I am pretty apted at Linux, Docker and Home Assistant is pretty new to me.

I’ve got most of it worked out but I was hoping to modify one of my automation this long weekend.
I found the Workday sensor in Home Assistant, but it is out of sync by +10 hours, (my timezone).
Discussion at Workday sensor triggering at midday not midnight indicates that the Timezone environment variable is set to UTC.

What is the correct way to change this in Docker and could it be adjusted in the installation script to be the same as locally?

Thank you